classification
Title: Distutls fails with MSVC++ 2008on Windows Vista 64bit
Type: compile error Stage:
Components: Distutils, Extension Modules, Windows Versions: Python 2.7, Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: msvc9compiler.py: ValueError when trying to compile with VC Express
View: 7511
Assigned To: tarek Nosy List: ipatrol, skrah, srid, tarek
Priority: normal Keywords:

Created on 2010-07-11 13:36 by ipatrol, last changed 2010-07-11 17:54 by srid. This issue is now closed.

Messages (2)
msg110008 - (view) Author: (ipatrol) Date: 2010-07-11 13:36
Trying to compile any extension module fails with the following error:

running install
running build
running build_ext
building 'bsdiff' extension
Traceback (most recent call last):
  File "setup.py", line 56, in <module>
    ext_modules = [extension])
  File "C:\hp\bin\Python\lib\distutils\core.py", line 152, in setup
    dist.run_commands()
	[Skipping many levels for brevity]
  File "C:\hp\bin\Python\lib\distutils\msvc9compiler.py", line 469, in compile
    self.initialize()
  File "C:\hp\bin\Python\lib\distutils\msvc9compiler.py", line 379, in initialize
    vc_env = query_vcvarsall(VERSION, plat_spec)
  File "C:\hp\bin\Python\lib\distutils\msvc9compiler.py", line 295, in query_vcvarsall
    raise ValueError(str(list(result.keys())))
ValueError: [u'path']

here, \hp\bin is a vista symlink to Python's directory. This is the second version that had this error, with several modules as well.

It appears to be an issue in msvc9compiler's handling of stdout, will try to patch.
msg110011 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2010-07-11 13:55
Duplicate of issue 7511.
History
Date User Action Args
2010-07-11 17:54:49sridsetnosy: + srid
2010-07-11 14:19:12mark.dickinsonsetstatus: open -> closed
resolution: duplicate
superseder: msvc9compiler.py: ValueError when trying to compile with VC Express
2010-07-11 13:55:47skrahsetnosy: + skrah
messages: + msg110011
2010-07-11 13:36:58ipatrolcreate