classification
Title: segmentation fault
Type: Stage:
Components: Interpreter Core Versions: Python 2.3
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: tim.peters Nosy List: cemason, rhettinger, tim.peters, zgoda
Priority: normal Keywords:

Created on 2004-03-03 19:53 by cemason, last changed 2004-04-06 00:02 by tim.peters. This issue is now closed.

Messages (5)
msg20172 - (view) Author: Chuck Mason (cemason) Date: 2004-03-03 19:53
$ python
Python 2.3.1 (#1, Sep 23 2003, 10:07:41)
[GCC 3.2.2 20030222 (Red Hat Linux 3.2.2-5)] on linux2
Type "help", "copyright", "credits" or "license" for
more information.
>>> def func(*a): print a
...
>>> func((1, 2, 3)
... )Segmentation fault


--------------------------
Not sure what other information you need, but I tested
it on several machines with the same version and it
seems to be hardware/other library independant.

msg20173 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2004-03-04 04:05
Logged In: YES 
user_id=80475

On WinMe, I cannot reproduce this on Py2.2.3,  Py2.3.3, or
Py2.4a0.
msg20174 - (view) Author: Jarek Zgoda (zgoda) Date: 2004-03-04 08:59
Logged In: YES 
user_id=92222

No such weirdness on W2KSp4 with Python 2.3.2
msg20175 - (view) Author: Tim Peters (tim.peters) * (Python committer) Date: 2004-03-04 14:59
Logged In: YES 
user_id=31435

Get into a debugger and show the top dozen functions on the 
call stack when the segfault occurs.  Segfaults in an 
interactive shell unique to Unixish systems usually get pinned 
on GNU readline in the end.
msg20176 - (view) Author: Tim Peters (tim.peters) * (Python committer) Date: 2004-04-06 00:02
Logged In: YES 
user_id=31435

It's been a month without any requested followup info, and 
nobody has been able to reproduce it, so closing it as 
WorksForMe.
History
Date User Action Args
2004-03-03 19:53:54cemasoncreate