classification
Title: cgi.py bug report + fix: tailing carriage return and newline characters in multipart cgi input broken
Type: behavior Stage:
Components: Library (Lib) Versions: Python 3.1, Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: flox, wobsta
Priority: normal Keywords: patch

Created on 2010-05-28 20:54 by wobsta, last changed 2011-01-17 21:58 by wobsta. This issue is now closed.

Files
File name Uploaded Description Edit
fix-cgi.patch wobsta, 2010-05-28 20:54 correct and extend the tests + fixes to the stdlib
Messages (2)
msg106691 - (view) Author: Andre Wobst (wobsta) Date: 2010-05-28 20:54
There are serious bugs in carriage return and newline handling at the end of a multipart cgi input. The enclosed patch extends the test_cgi.py (and actually reverts two wrong tests to what they had been for python2.x). Additionally, the bugs are fixed by two small corrections to cgi.py and email/feedparser.py. Thanks for consideration.
msg126439 - (view) Author: Andre Wobst (wobsta) Date: 2011-01-17 21:58
I just declare this bug to be a duplicate of #4953. Due to the recent fix r87998 of the cgi module my extended/corrected testcases attached in this bug report now pass.
History
Date User Action Args
2011-01-17 21:58:10wobstasetstatus: open -> closed

messages: + msg126439
resolution: duplicate
nosy: flox, wobsta
2010-08-27 03:21:30floxsetnosy: + flox

versions: + Python 3.2
2010-05-28 20:56:35wobstasettype: behavior
versions: + Python 3.1, - Python 3.3
2010-05-28 20:54:36wobstacreate