classification
Title: need console/pager module
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.3, Python 2.7
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, eric.araujo, ezio.melotti, r.david.murray, techtonik
Priority: normal Keywords:

Created on 2010-04-15 08:01 by techtonik, last changed 2010-04-16 12:50 by r.david.murray. This issue is now closed.

Messages (5)
msg103187 - (view) Author: anatoly techtonik (techtonik) Date: 2010-04-15 08:01
Many many Python tools have duplicating code related to getting console properties like width and height to provide pagination and cute progress bars. While the issue seems minor, making such features work crossplatform way requires many tuits. That's why it is highly desirable to have console module inside Python stdlib.
msg103190 - (view) Author: anatoly techtonik (techtonik) Date: 2010-04-15 10:45
How to get console width:

http://stackoverflow.com/questions/566746/how-to-get-console-window-width-in-python
http://code.activestate.com/recipes/440694-determine-size-of-console-window-on-windows/

PDCurses may contain some public domain code:
http://pdcurses.sourceforge.net/
BSD like licensed Console module from Fredrik Lundh:
http://effbot.org/zone/console-handbook.htm
msg103252 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2010-04-15 20:36
Please propose on python-ideas before making a bug.
msg103297 - (view) Author: anatoly techtonik (techtonik) Date: 2010-04-16 06:52
It is not a bug, but a "feature request".
msg103319 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-04-16 12:50
Benjamin was using the term 'bug' as a synonym for 'issue in the tracker'.  The point is that a feature like this (a whole new module) is not an appropriate tracker item.  In most cases the procedure for getting a new module included in the stdlib is distinctly non-trivial and generally requires, among other things, that the module get proven by distribution via PyPI first.
History
Date User Action Args
2010-04-16 12:50:47r.david.murraysetnosy: + r.david.murray
messages: + msg103319
2010-04-16 07:06:28ezio.melottisetnosy: + ezio.melotti

stage: resolved
2010-04-16 06:52:46techtoniksetmessages: + msg103297
2010-04-15 21:24:17eric.araujosetnosy: + eric.araujo
2010-04-15 20:36:54benjamin.petersonsetstatus: open -> closed

nosy: + benjamin.peterson
messages: + msg103252

resolution: rejected
2010-04-15 10:45:48techtoniksetmessages: + msg103190
2010-04-15 08:01:46techtonikcreate