classification
Title: test_threading
Type: Stage:
Components: Build Versions: Python 2.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: brett.cannon Nosy List: brett.cannon, sleard1
Priority: normal Keywords:

Created on 2003-08-19 21:32 by sleard1, last changed 2004-02-27 07:35 by brett.cannon. This issue is now closed.

Files
File name Uploaded Description Edit
test.out sleard1, 2003-09-08 21:02 gmake test output
Messages (6)
msg17847 - (view) Author: Shawn Leard (sleard1) Date: 2003-08-19 21:32
Due the problems reported with version 2.3 I thought I
would give version 2.2.3 a shot. The problem I am
having here is no matter what switches I pass configure
to disable threading it still tries to test them and as
a result the make test fails.

168 tests OK.
1 test failed:
    test_threading
24 tests skipped:
    test_al test_asynchat test_bsddb test_cd test_cl
test_curses
    test_dl test_email_codecs test_fork1 test_gl
test_imgfile
    test_linuxaudiodev test_minidom test_openpty
test_pyexpat
    test_queue test_sax test_socket_ssl
test_socketserver test_thread
    test_threaded_import test_threadedtempfile test_winreg
    test_winsound

--------

./configure --prefix=/usr/local --with-gnu-ld
--with-as=/usr/local/bin/as --with-ld=/usr/local/bin/ld
--enable-nls   --with-included-gettext --with-fpectl
--with-threads=no --without-threads --disable-threads
--with-gnu-as

--------

mars$ /files/local/src/Python-2.2.3/python
test_threading.py
Traceback (most recent call last):
  File "test_threading.py", line 7, in ?
    import threading
  File
"/files/local/src/Python-2.2.3/Lib/threading.py", line
5, in ?
    import thread
ImportError: No module named thread
msg17848 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2003-09-05 01:53
Logged In: YES 
user_id=357491

In order to better debug this, can you state what the line says 
when test_threading fails; e.g., "test_sunaudiodev skipped -- ..."?

The test will be run regardless of whether you compiled with 
threads or not, but it should be listed as a skip instead of a 
failure.
msg17849 - (view) Author: Shawn Leard (sleard1) Date: 2003-09-08 20:00
Logged In: YES 
user_id=328879



I will give this a shot and get back to you.

msg17850 - (view) Author: Shawn Leard (sleard1) Date: 2004-02-17 13:51
Logged In: YES 
user_id=328879



Brett,

I am going to close this because the box I had was
redeployed and I have no longer had this problem.

Best Regards,

Shawn
msg17851 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2004-02-17 21:24
Logged In: YES 
user_id=357491

That's fine, Shawn, but I still feel the need to look into it.  There is no 
reason for that to be happening.  I feel I should at least verify that this 
doesn't happen on my box because if it does there is a bug somewhere.
msg17852 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2004-02-27 07:35
Logged In: YES 
user_id=357491

OK, I didn't get this with CVS Python 2.3 so I am closing this as invalid.
History
Date User Action Args
2003-08-19 21:32:00sleard1create