Title: traceback module not properly printing exceptions on interpreter shutdown
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.5, Python 3.4, Python 2.7
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, georg.brandl, gps, haypo, jyasskin, marienz, rtyler
Priority: normal Keywords:

Created on 2009-11-16 23:23 by rtyler, last changed 2014-10-01 01:55 by berker.peksag. This issue is now closed.

Messages (3)
msg95361 - (view) Author: R. Tyler Ballance (rtyler) Date: 2009-11-16 23:23
Receiving a traceback when shutting down an interpreter with threads 
spawned inside of it:

Traceback (most recent call last):
  File "/usr/lib/python2.6/", line 497, in __bootstrap
  File "/usr/lib/python2.6/", line 538, in __bootstrap_inner
    (, _format_exc()))
  File "/usr/lib/python2.6/", line 235, in format_exc
    etype, value, tb = sys.exc_info()
AttributeError: 'NoneType' object has no attribute 'exc_info'

According to mzz on #Python:

17:29 < mzz> rtyler: I think this is worth a bug report. If you look up you'll find (assuming our line numbers match) that bit 
of code actually goes out of its way to deal with the shutdown problem 
I mentioned, but then it calls into the traceback module, which doesn't.
msg228016 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-09-30 22:30
Is this still a problem?  How do I go about reproducing it, assuming that I can on Windows?
msg228018 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2014-09-30 22:32
Sorry rtyler but we need much more information to investigate your issue. Since the issue was reported 5 years ago, I don't expect feedback and I prefer to close it as out of date.
Date User Action Args
2014-10-01 01:55:09berker.peksagsetstage: needs patch -> resolved
2014-09-30 22:32:56hayposetstatus: open -> closed

nosy: + haypo
messages: + msg228018

resolution: out of date
2014-09-30 22:30:27BreamoreBoysetnosy: + BreamoreBoy

messages: + msg228016
versions: + Python 3.4, Python 3.5, - Python 3.1, Python 3.2
2012-10-06 11:20:23georg.brandlsetassignee: georg.brandl ->
2010-07-11 10:49:24BreamoreBoysetassignee: georg.brandl
versions: - Python 2.6
nosy: + georg.brandl
2009-11-17 00:09:59pitrousetpriority: normal
versions: + Python 3.1, Python 2.7, Python 3.2
components: + Library (Lib), - Interpreter Core

nosy: + jyasskin, gps
title: threading module not properly handling shutdown -> traceback module not properly printing exceptions on interpreter shutdown
type: crash -> behavior
stage: needs patch
2009-11-16 23:36:35marienzsetnosy: + marienz
2009-11-16 23:23:58rtylercreate