classification
Title: setup build with Platform SDK, finding vcvarsall.bat
Type: behavior Stage:
Components: Distutils Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: msvc9compiler.py: ValueError when trying to compile with VC Express
View: 7511
Assigned To: tarek Nosy List: MarcMarc, python-dev, skrah, tarek
Priority: normal Keywords:

Created on 2009-05-08 14:03 by MarcMarc, last changed 2012-09-23 09:13 by python-dev. This issue is now closed.

Messages (3)
msg87442 - (view) Author: Marc Schoenefeld (MarcMarc) Date: 2009-05-08 14:03
Hi, 

I have the M$ Platform SDK installed, which 
is a free (as don't pay) alternative to 
VisualStudio.   

in order to achieve a successful compile with 
setup.py build on the Platform SDK I 
had to add the following change in 
distutils/msvc9compiler.py: 

Best regards
Marc 

Patch draft:

def find_vcvarsall(version):
       
+   vcvarsall = os.path.join(productdir+"\\bin", "vcvars32.bat")
-   vcvarsall = os.path.join(productdir, "vcvarall.bat")

 
   if os.path.isfile(vcvarsall):
msg96957 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2009-12-28 16:05
Duplicate of issue 7511.
msg171021 - (view) Author: Roundup Robot (python-dev) Date: 2012-09-23 09:13
New changeset abf23c22231e by Victor Stinner in branch 'default':
Issue #5969: faulthandler module: rename dump_tracebacks_later() to
http://hg.python.org/cpython/rev/abf23c22231e
History
Date User Action Args
2012-09-23 09:13:20python-devsetnosy: + python-dev
messages: + msg171021
2010-06-19 21:36:09georg.brandlsetstatus: open -> closed
resolution: duplicate
superseder: msvc9compiler.py: ValueError when trying to compile with VC Express
2009-12-28 16:05:19skrahsetnosy: + skrah
messages: + msg96957
2009-05-08 14:03:45MarcMarccreate