classification
Title: _json: _convertPyInt_AsSsize_t() never raise any error
Type: Stage:
Components: Library (Lib) Versions: Python 3.0, Python 3.1, Python 2.7, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: georg.brandl, haypo
Priority: normal Keywords: patch

Created on 2009-05-05 00:21 by haypo, last changed 2009-05-05 07:49 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
json_error.patch haypo, 2009-05-05 00:21
Messages (2)
msg87191 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2009-05-05 00:21
_convertPyInt_AsSsize_t() always return 1 (success) even on 
PyInt_AsSsize_t() error because of a ";" after the if...

    if (*size_ptr == -1 && PyErr_Occurred());
        return 1;

Attached patch fixes this issue, and add a regression test.
msg87216 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-05-05 07:49
Applied in r72314.
History
Date User Action Args
2009-05-05 07:49:38georg.brandlsetstatus: open -> closed

nosy: + georg.brandl
messages: + msg87216

resolution: fixed
2009-05-05 00:21:50haypocreate