classification
Title: closing stdout in a child process on cygwin means that process doesn't receive bytes from stdin anymore. I think.
Type: behavior Stage: resolved
Components: Interpreter Core Versions: Python 2.5
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: exarkun, stutzbach, zooko
Priority: normal Keywords:

Created on 2008-11-10 22:57 by zooko, last changed 2010-04-27 15:34 by stutzbach. This issue is now closed.

Files
File name Uploaded Description Edit
parent.py stutzbach, 2009-03-29 22:41
child.py stutzbach, 2009-03-29 22:42
Messages (4)
msg75711 - (view) Author: Zooko O'Whielacronx (zooko) Date: 2008-11-10 22:57
When someone runs "bin/trial --reactor=select 
twisted.internet.test.test_process.ProcessTestsBuilder_PollReactor.test_
childConnectionLost" on cygwin, using the cygwin version of Python, 
either manually (which I've done on two cygwin installations), or from 
the twisted buildbot -- 
http://buildbot.twistedmatrix.com/builders/cygwin-py2.5-select -- then 
once the child process closes its fd #2, it subsequently receives no 
further bytes from its fd #1, even though the parent process has written 
some bytes to that pipe.

I can reproduce this by running the Twisted unit tests, like this:

step 1: get twisted:

svn co svn://svn.twistedmatrix.com/svn/Twisted/trunk twisted

step 2: cd into the top-level directory, and run trial:

cd twisted && python ./bin/trial --reactor=select 
twisted.internet.test.test_process.ProcessTestsBuilder_PollReactor.test_
childConnectionLost

On other platforms that cygwin (see the Twisted buildbot -- 
http://buildbot.twistedmatrix.com/supported?branch=trunk -- then this 
test exits quickly with success. On cygwin, using cygwin python.exe, 
this test instead enter an infinite loop as the child waits to receive 
further bytes on its stdin, and the parent waits for the child to 
respond to those bytes. (This doesn't happen on cygwin with the standard 
Win32 build of python.exe, of course, anymore than it happens on a 
Windows system without cygwin installed when using that executable.)

I've opened a ticket about this on the twisted issue tracker as well: 

http://twistedmatrix.com/trac/ticket/3529 # closing stdout in a child 
process on cygwin means that process doesn't receive bytes from stdin 
anymore. I think.
msg75712 - (view) Author: Zooko O'Whielacronx (zooko) Date: 2008-11-10 23:19
I opened a ticket on the cygwin issue tracker:

http://sourceware.org/bugzilla/show_bug.cgi?id=7017 # closing stdout in a 
child python process means that process doesn't receive bytes from stdin 
anymore. I think.
msg75830 - (view) Author: Zooko O'Whielacronx (zooko) Date: 2008-11-13 16:09
Corinna Vinschen of cygwin requests a smaller test case:

http://www.cygwin.com/ml/cygwin/2008-11/msg00166.html
msg84442 - (view) Author: Daniel Stutzbach (stutzbach) (Python committer) Date: 2009-03-29 22:41
I created a simple parent/child pair using subprocess under cygwin and
Python 2.5 and for me closing stdout did not affect stdin.

It would appear the problem is caused by something else?
History
Date User Action Args
2010-04-27 15:34:06stutzbachsetstatus: open -> closed
resolution: works for me
stage: resolved
2009-03-29 22:42:11stutzbachsetfiles: + child.py
2009-03-29 22:42:00stutzbachsetfiles: + parent.py
nosy: + stutzbach
messages: + msg84442

2008-11-13 16:09:41zookosetmessages: + msg75830
2008-11-13 14:08:47exarkunsetnosy: + exarkun
2008-11-10 23:19:31zookosetmessages: + msg75712
2008-11-10 22:57:11zookocreate