classification
Title: Python 3.0 docs are broken.
Type: compile error Stage: needs patch
Components: Documentation Versions: Python 3.0, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: barry, georg.brandl, wplappert
Priority: deferred blocker Keywords:

Created on 2008-11-06 04:14 by barry, last changed 2008-11-07 08:13 by georg.brandl. This issue is now closed.

Messages (9)
msg75544 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2008-11-06 04:14
The Python 3.0 documentation is broken.  This is blocking the 3.0rc2
release.
I'm too tired right now to figure out what the base problem is.

This was during the ".../release.py --export 3.0rc2" build phase.

pdflatex 'c-api.tex'
This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
(./c-api.tex
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german,
ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch,
esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar,
norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish,
swedish, tur
kish, ukrainian, nohyphenation, loaded.
(./manual.cls
Document Class: manual 2008/10/18 Document class (Sphinx manual)
(/opt/local/share/texmf-dist/tex/latex/base/report.cls
Document Class: report 2004/02/16 v1.4f Standard LaTeX document class
(/opt/local/share/texmf-dist/tex/latex/base/size10.clo)))
(/opt/local/share/texmf-dist/tex/latex/base/inputenc.sty
(/opt/local/share/texmf-dist/tex/latex/base/utf8.def
(/opt/local/share/texmf-dist/tex/latex/base/t1enc.dfu)
(/opt/local/share/texmf-dist/tex/latex/base/ot1enc.dfu)
(/opt/local/share/texmf-dist/tex/latex/base/omsenc.dfu)))
(/opt/local/share/texmf-dist/tex/latex/base/fontenc.sty
(/opt/local/share/texmf-dist/tex/latex/base/t1enc.def))
(/opt/local/share/texmf-dist/tex/generic/babel/babel.sty
(/opt/local/share/texmf-dist/tex/generic/babel/english.ldf
(/opt/local/share/texmf-dist/tex/generic/babel/babel.def)))
(/opt/local/share/texmf-dist/tex/latex/psnfss/times.sty) (./fncychap.sty)
(./sphinx.sty (/opt/local/share/texmf-dist/tex/latex/base/textcomp.sty
(/opt/local/share/texmf-dist/tex/latex/base/ts1enc.def
(/opt/local/share/texmf-dist/tex/latex/base/ts1enc.dfu)))
(/opt/local/share/texmf-dist/tex/latex/fancyhdr/fancyhdr.sty)
(/opt/local/share/texmf-dist/tex/latex/fancybox/fancybox.sty
Style option: `fancybox' v1.3 <2000/09/19> (tvz)
) (/opt/local/share/texmf-dist/tex/latex/titlesec/titlesec.sty)
(./tabulary.sty
(/opt/local/share/texmf-dist/tex/latex/tools/array.sty))
(/opt/local/share/texmf-dist/tex/latex/amsmath/amsmath.sty
For additional information on amsmath, use the `?' option.
(/opt/local/share/texmf-dist/tex/latex/amsmath/amstext.sty
(/opt/local/share/texmf-dist/tex/latex/amsmath/amsgen.sty))
(/opt/local/share/texmf-dist/tex/latex/amsmath/amsbsy.sty)
(/opt/local/share/texmf-dist/tex/latex/amsmath/amsopn.sty))
(/opt/local/share/texmf-dist/tex/latex/base/makeidx.sty)
(/opt/local/share/texmf-dist/tex/latex/framed/framed.sty)
(/opt/local/share/texmf-dist/tex/latex/graphics/color.sty
(/opt/local/share/texmf-dist/tex/latex/graphics/color.cfg)
(/opt/local/share/texmf-dist/tex/latex/graphics/pdftex.def))
(/opt/local/share/texmf-dist/tex/latex/fancyvrb/fancyvrb.sty
Style option: `fancyvrb' v2.6, with DG/SPQR fixes <1998/07/17> (tvz)
(/opt/local/share/texmf-dist/tex/latex/graphics/keyval.sty)
No file fancyvrb.cfg.
) (/opt/local/share/texmf-dist/tex/latex/graphics/graphicx.sty
(/opt/local/share/texmf-dist/tex/latex/graphics/graphics.sty
(/opt/local/share/texmf-dist/tex/latex/graphics/trig.sty)
(/opt/local/share/texmf-dist/tex/latex/graphics/graphics.cfg)))
(/opt/local/share/texmf-dist/tex/plain/pdfcolor/pdfcolor.tex)
! Extra \fi.
l.62 \fi\fi
           
?
msg75545 - (view) Author: Winfried Plappert (wplappert) Date: 2008-11-06 05:28
This is a simple one to fix: remove the second \fi on the incriminated
line in sphinx.sty, line 62. I just checked out Sphinx version 67115 and
retested. With my fix = removal of the second \fi, the make process works.  

The issue also applies to Python 2.6.
msg75546 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-11-06 07:36
The issue is not as "easy" as it seems (or at least that's what I believe).

Barry, if you install the xetex package, the build should run fine.
msg75549 - (view) Author: Winfried Plappert (wplappert) Date: 2008-11-06 08:40
In other words, the various *Tex packages cannot agree on a common syntax?

MiKTeX-pdfTeX 2.7.3147 (1.40.9) (MiKTeX 2.7) also complains about the
double \fi.
msg75550 - (view) Author: Winfried Plappert (wplappert) Date: 2008-11-06 08:54
And Ubuntu Linux pdflatex complains as well:
/usr/bin/pdflatex from package texlive-latex-base.
msg75552 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-11-06 09:11
> In other words, the various *Tex packages cannot agree on a common syntax?

No, syntax has nothing to do with it. It was a mistake of some sort on
my part. It depends on whether the "ifxetex" latex package is present,
because that already defines the \ifxetex command.

I've now fixed it in Sphinx tip, and copied it to SVN so that Barry
needn't do anything except "make update" before trying to build the docs
again.
msg75590 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2008-11-07 02:07
Sorry, but this is still not fixed:

tnow using/cmdline Exception occurred:
  File
"/private/tmp/py3k/dist/Python-3.0rc2/Doc/tools/docutils/parsers/rst/states.py",
line 2055, in run_directive
    % (type_name, i, result[i]))
AssertionError: Directive "seealso" returned non-Node object (index 0):
[<system_message: <paragraph...><literal_block...>>, <paragraph:
<pending_xref...>>]
The full traceback has been saved in
/var/folders/by/bycjwwYpGcm-aejnq3kFc++++TI/-Tmp-/sphinx-err-uh9riS.log,
if you want to report the issue to the author.
Please also report this if it was a user error, so that a better error
message can be provided next time.
Send reports to sphinx-dev@googlegroups.com. Thanks!
make[1]: *** [build] Error 1
make: *** [dist] Error 2


Verified on both OS X and Ubuntu Intrepid.  Verified on irc by Christian
Heimes.
msg75591 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2008-11-07 03:07
r67136 is a workaround found by Christian.  We'll go with this for the
3.9rc2 release and make this a deferred blocker for a proper fix for the
next rc.
msg75599 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-11-07 08:13
Actually, that the build doesn't work is almost OK, because that seealso
directive was invalid markup syntax (until very recently) :)

Anyway, should be fixed now after a "make update".
History
Date User Action Args
2008-11-07 08:13:22georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg75599
2008-11-07 03:07:25barrysetpriority: release blocker -> deferred blocker
resolution: fixed -> (no value)
messages: + msg75591
2008-11-07 02:07:40barrysetstatus: closed -> open
messages: + msg75590
2008-11-06 09:11:28georg.brandlsetstatus: open -> closed
resolution: fixed
2008-11-06 09:11:15georg.brandlsetmessages: + msg75552
2008-11-06 08:54:33wplappertsetmessages: + msg75550
2008-11-06 08:40:25wplappertsetmessages: + msg75549
2008-11-06 07:37:00georg.brandlsetmessages: + msg75546
2008-11-06 05:28:18wplappertsetnosy: + wplappert
messages: + msg75545
versions: + Python 2.6
2008-11-06 04:14:54barrycreate