classification
Title: IDLE does not open too
Type: Stage:
Components: IDLE Versions: Python 2.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: VitP, ec2929, loewis, pi, zeromtmu
Priority: normal Keywords: patch

Created on 2008-10-06 00:31 by Chris_L, last changed 2009-11-15 01:34 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
idle.patch giampaolo.rodola, 2008-10-18 15:49
Messages (16)
msg74357 - (view) Author: Chris (Chris_L) Date: 2008-10-06 00:31
IDLE just won't open in 2.6 for me. The command line works but not the
GUI. It works in 2.5.2 though. I am a neophyte, any help is much
appreciated.
msg74359 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-10-06 05:02
What operating system are you using?
msg74360 - (view) Author: Rajanikanth Jammalamadaka (Raj) Date: 2008-10-06 05:52
Hi! Chris,

I am assuming that you are using Vista. If you are..then you need to 
enable the Administrator user (following the instructions here: 
http://www.computerperformance.co.uk/vista/vista_administrator_activate.
htm) and then install python for all users by logging in as the 
Administrator.

Thanks,

Raj
msg74817 - (view) Author: Chris Ozeroff (scionkiller) Date: 2008-10-15 21:05
This bug does not just affect Vista.

I am running Windows XP Professional x64 and encountered the same
problem. Everything appeared to go fine on the installation, but then
IDLE just refuses to run, nothing appears in the task manager, no
errors, nothing. Command line still works.

When I read Raj's coment, I realized that I had only installed it for
me, not for all users. Installing it the other way worked.

This seems like a pretty serious bug, because users (like me) are
probably going to be totally baffled as to the cause, since there is no
feedback.

Thanks for the workaround!
msg74819 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-10-15 21:16
> I am running Windows XP Professional x64 and encountered the same
> problem. Everything appeared to go fine on the installation, but then
> IDLE just refuses to run, nothing appears in the task manager, no
> errors, nothing. Command line still works.

It's normal that there are no errors. They get to stderr, and there is
no stderr in a GUI application.

Can you please try these steps, and report results?
1. open cmd.exe
2. cd \python26
3. python.exe Lib\idlelib\idle.py

Report any output that this produces.

> This seems like a pretty serious bug

I don't think it's pretty serious. It has a workaround; a "pretty
serious" bug doesn't have one.
msg74953 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2008-10-18 15:49
> It's normal that there are no errors. They get to stderr, and there is
> no stderr in a GUI application.

Maybe it would make sense putting the main() function into a try/except
statement and pop-up a message box to display the error.
A patch is in attachment.
msg75138 - (view) Author: nut (zeromtmu) Date: 2008-10-23 10:50
would you help me to open IDLE it can't open in 2.6 version but can use 
python in terminal my OS is MacOSX. I'm the new one in python so, i need 
you help very much.
msg75272 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-10-28 05:41
Giampaolo: I'm skeptical that the patch helps. If you can't start IDLE
because you cannot import Tkinter, displaying the error in a
tkMessageBox will do no good, either.
msg76359 - (view) Author: Elizabeth Chang (ec2929) Date: 2008-11-24 20:11
I have this problem too but I am running Python 2.5.2 on Windows XP 
professional. I did install Python for all users. I tried uninstalling 
and reinstalling Python. IDLE does not open for me. It cannot find 
Tkinker.

C:\Python25>python.exe lib\idlelib\idle.py
Traceback (most recent call last):
  File "lib\idlelib\idle.py", line 6, in <module>
    import PyShell
  File "C:\Python25\Lib\idlelib\PyShell.py", line 14, in <module>
    import macosxSupport
  File "C:\Python25\Lib\idlelib\macosxSupport.py", line 6, in <module>
    import Tkinter
ImportError: No module named Tkinter
msg76366 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-11-24 21:45
> I have this problem too but I am running Python 2.5.2 on Windows XP 
> professional.

That is most definitely a different problem from the one reported here
originally.

> I did install Python for all users. I tried uninstalling 
> and reinstalling Python. IDLE does not open for me. It cannot find 
> Tkinker.

Make sure you select Tkinter in the feature selection window of Python.
If you can't get it to work, and still believe you have found a bug,
please report it as a separate issue.
msg77212 - (view) Author: I. Stead (VitP) Date: 2008-12-07 04:23
This still seems to be happening in python 3.0 as well. Here is the
output from
>1. open cmd.exe
>2. cd \python26
>3. python.exe Lib\idlelib\idle.py

C:\Program Files\Python>python.exe Lib\idlelib\idle.py
Traceback (most recent call last):
  File "Lib\idlelib\idle.py", line 22, in <module>
    idlelib.PyShell.main()
  File "C:\Program Files\Python\lib\idlelib\PyShell.py", line 1385, in main
    shell = flist.open_shell()
  File "C:\Program Files\Python\lib\idlelib\PyShell.py", line 276, in
open_shell

    self.pyshell = PyShell(self)
  File "C:\Program Files\Python\lib\idlelib\PyShell.py", line 800, in
__init__
    OutputWindow.__init__(self, flist, None, None)
  File "C:\Program Files\Python\lib\idlelib\OutputWindow.py", line 16,
in __init
__
    EditorWindow.__init__(self, *args)
  File "C:\Program Files\Python\lib\idlelib\EditorWindow.py", line 243,
in __ini
t__
    self.update_recent_files_list()
  File "C:\Program Files\Python\lib\idlelib\EditorWindow.py", line 761,
in updat
e_recent_files_list
    rf_file = open(self.recent_files_path, 'w')
  File "C:\Program Files\Python\lib\io.py", line 278, in __new__
    return open(*args, **kwargs)
  File "C:\Program Files\Python\lib\io.py", line 222, in open
    closefd)
  File "C:\Program Files\Python\lib\io.py", line 615, in __init__
    _fileio._FileIO.__init__(self, name, mode, closefd)
IOError: [Errno 13] Permission denied:
'C:\\Users\\Isaac\\.idlerc\\recent-files.
lst'
msg77337 - (view) Author: Elizabeth Chang (ec2929) Date: 2008-12-08 20:21
I fixed this by copying the tcl8.4 and tk8.4 directories into 
Python25/Lib from Python25/tcl. This fixes it but it should work 
without having to do this. I start new ticket and reference this one.
msg77339 - (view) Author: Elizabeth Chang (ec2929) Date: 2008-12-08 20:22
Issue 4598 created.
msg78476 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-12-29 18:59
Since there was no feedback from the OP, I'm closing this as "works for me".
msg95266 - (view) Author: Patricia Irwin (pi) Date: 2009-11-15 00:31
Hi, 

I'm running Windows XP Professional and just installed Python 2.6. I
installed it for all users. Tried starting up IDLE and nothing happened.
I read the boards here, and it looks like others have had similar
troubles. I read on this board that moving the Tcl/Tk directories
helped, so I tried moving the tcl8.5 and tk8.5 directories to
C:\Python26\Lib, but IDLE still wouldn't start up. (So I moved them back.)

I opened a command shell and tried running idle that way. I will paste
the output below. Could someone help with this? Sorry if this is the
wrong place to post this problem; I am Python newbie.

C:\Python26>python Lib\idlelib\idle.py

Traceback (most recent call last):
  File "Lib\idlelib\idle.py", line 21, in <module>
    idlelib.PyShell.main()
  File "C:\Python26\lib\idlelib\PyShell.py", line 1400, in main
    shell = flist.open_shell()
  File "C:\Python26\lib\idlelib\PyShell.py", line 279, in open_shell
    self.pyshell = PyShell(self)
  File "C:\Python26\lib\idlelib\PyShell.py", line 820, in __init__
    OutputWindow.__init__(self, flist, None, None)
  File "C:\Python26\lib\idlelib\OutputWindow.py", line 16, in __init__
    EditorWindow.__init__(self, *args)
  File "C:\Python26\lib\idlelib\EditorWindow.py", line 234, in __init__
    self.update_recent_files_list()
  File "C:\Python26\lib\idlelib\EditorWindow.py", line 755, in
update_recent_fil
es_list
    rf_file = open(self.recent_files_path, 'w')
IOError: [Errno 13] Permission denied: 'C:\\Documents and
Settings\\Tricia\\.idl
erc\\recent-files.lst'
msg95270 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-11-15 01:34
Patricia, if you want to report a bug, please don't follow up to an
existing, closed bug report.

If you are just asking for help: delete the folder .idlerc and all of
its files, and retry.
History
Date User Action Args
2009-11-15 01:34:39loewissetmessages: + msg95270
2009-11-15 00:31:09pisetnosy: + pi

messages: + msg95266
versions: + Python 2.6, - Python 3.0
2008-12-29 18:59:19loewissetstatus: open -> closed
resolution: works for me
messages: + msg78476
2008-12-08 20:22:31ec2929setmessages: + msg77339
2008-12-08 20:21:05ec2929setmessages: + msg77337
2008-12-07 04:23:10VitPsetnosy: + VitP
messages: + msg77212
versions: + Python 3.0, - Python 2.6
2008-11-24 21:45:35loewissetmessages: + msg76366
2008-11-24 20:11:04ec2929setnosy: + ec2929
messages: + msg76359
2008-10-28 05:41:59loewissetnosy: + loewis
messages: + msg75272
2008-10-23 10:50:53zeromtmusetnosy: + zeromtmu, - loewis, giampaolo.rodola, Raj, Chris_L, scionkiller
messages: + msg75138
components: + IDLE
title: IDLE does not open at all -> IDLE does not open too
2008-10-18 15:49:28giampaolo.rodolasetfiles: + idle.patch
nosy: + giampaolo.rodola
messages: + msg74953
keywords: + patch
2008-10-15 21:16:02loewissetmessages: + msg74819
2008-10-15 21:05:32scionkillersetnosy: + scionkiller
messages: + msg74817
2008-10-06 05:52:46Rajsetnosy: + Raj
messages: + msg74360
2008-10-06 05:02:05loewissetnosy: + loewis
messages: + msg74359
2008-10-06 00:31:20Chris_Lcreate