classification
Title: Sphinx producing duplicate id attributes, HTML fails validation.
Type: behavior Stage:
Components: Documentation tools (Sphinx) Versions: Python 2.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: georg.brandl, gjhiggins
Priority: normal Keywords:

Created on 2008-09-01 10:02 by gjhiggins, last changed 2008-09-09 22:07 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
index.html gjhiggins, 2008-09-07 10:50 generated html file
Messages (4)
msg72221 - (view) Author: Graham Higgins (gjhiggins) Date: 2008-09-01 10:02
It seems Sphinx creates duplicate ids for <span> elements in Permalink 
headers. This causes Sphinx-generated HTML to fail W3C validation. 
Example:

http://docs.python.org/dev/tutorial/interpreter.html

where "id2" appears twice.
msg72223 - (view) Author: Graham Higgins (gjhiggins) Date: 2008-09-01 10:18
Um, hang fire. I need to do more analysis in order to reproduce the 
problem properly.
msg72736 - (view) Author: Graham Higgins (gjhiggins) Date: 2008-09-07 10:50
Now confirmed. To reproduce, run sphinx-quickstart with project name 
"Test", accepting all defaults. Execute "make html", examine 
.build/html/index.html to find:

<div class="section" id="welcome-to-test-s-documentation">
<h1 id="welcome-to-test-s-documentation">
msg72925 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-09-09 22:07
Thanks for the report! This was due to a docutils 0.4/0.5
incompatibility, which should now be fixed in r66355.
History
Date User Action Args
2008-09-09 22:07:44georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg72925
2008-09-07 10:50:49gjhigginssetfiles: + index.html
messages: + msg72736
2008-09-01 10:18:13gjhigginssetmessages: + msg72223
2008-09-01 10:02:16gjhigginscreate