classification
Title: latexwriter: \footnotemark can only take numbers as arguments
Type: Stage:
Components: Documentation tools (Sphinx) Versions:
process
Status: closed Resolution: postponed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: georg.brandl, pv
Priority: normal Keywords:

Created on 2008-08-23 21:11 by pv, last changed 2008-09-12 16:33 by georg.brandl. This issue is now closed.

Messages (2)
msg71817 - (view) Author: Pauli Virtanen (pv) Date: 2008-08-23 21:11
LaTeXTranslator.visit_footnote_reference generates improper Latex if 
the footnote marker given is not a number. This will result in a Latex 
error if the RST document contains footnotes where the marker is not a 
number.

The problem is that the Latex commands \footnotemark and \footnotetext 
apparently expect their [] argument to always be a number.

For example:

    \footnotemark[x]

results to error:

    ! Missing number, treated as zero.
    <to be read again> 
                       x
    l.4733 ...\footnotemark[x]
msg73106 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-09-12 16:33
This is now tracked in http://code.google.com/p/sphinx/issues/detail?id=13.
History
Date User Action Args
2008-09-12 16:33:46georg.brandlsetstatus: open -> closed
resolution: postponed
messages: + msg73106
2008-08-23 21:11:01pvcreate