classification
Title: invalid ref count on locale.strcoll() error
Type: crash Stage:
Components: Library (Lib) Versions: Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: loewis Nosy List: georg.brandl, haypo, loewis
Priority: high Keywords: patch

Created on 2008-07-06 16:06 by haypo, last changed 2008-07-20 20:45 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
locale_strcoll_rel1.patch haypo, 2008-07-06 16:06 Patch fixing refcount in strcoll error
Messages (3)
msg69336 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2008-07-06 16:06
If locale.strcoll(a, b) fails because PyUnicode_FromObject(b) fails, 
refcount of a is wrong. Attached patch fixes the problem.
msg69337 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2008-07-06 16:07
Example to reproduce the bug:

import locale; locale.strcoll(u"a", None)
msg70090 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-07-20 20:45
Fixed in r65134.
History
Date User Action Args
2008-07-20 20:45:03georg.brandlsetstatus: open -> closed
nosy: + georg.brandl
resolution: fixed
messages: + msg70090
2008-07-06 17:12:01loewissetpriority: high
2008-07-06 16:56:42georg.brandlsetassignee: loewis
nosy: + loewis
2008-07-06 16:07:27hayposetmessages: + msg69337
2008-07-06 16:06:09haypocreate