classification
Title: test_subprocess.test_leak_fast_process_del_killed() fails randomly on AMD64 FreeBSD 10.x Shared 3.6
Type: Stage: resolved
Components: Tests Versions: Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: haypo
Priority: normal Keywords:

Created on 2017-07-28 14:42 by haypo, last changed 2017-08-16 14:18 by haypo. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 2931 merged haypo, 2017-07-28 14:54
PR 3073 merged haypo, 2017-08-11 14:12
PR 3074 merged haypo, 2017-08-11 14:13
Messages (6)
msg299390 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-07-28 14:42
http://buildbot.python.org/all/builders/AMD64%20FreeBSD%2010.x%20Shared%203.6/builds/355/steps/test/logs/stdio

======================================================================
FAIL: test_leak_fast_process_del_killed (test.test_subprocess.POSIXProcessTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.6.koobs-freebsd10/build/Lib/test/test_subprocess.py", line 2434, in test_leak_fast_process_del_killed
    self.assertRaises(OSError, os.waitpid, pid, 0)
AssertionError: OSError not raised by waitpid
msg299401 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-07-28 16:00
New changeset cc42c121eb5346f673247f95dac575aadb77d66c by Victor Stinner in branch 'master':
bpo-31067: test_subprocess calls reap_children() (#2931)
https://github.com/python/cpython/commit/cc42c121eb5346f673247f95dac575aadb77d66c
msg300162 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-08-11 14:02
I tried and failed to reproduce the bug manually on the FreeBSD 10 buildbot.

I ran 14 iterations of "./python -m test test_subprocess -v -F --fail-env-changed" and 50 iterations of "./python -m test test_subprocess -m  test_leak_fast_process_del_killed -F".
msg300165 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-08-11 15:14
New changeset 504939fdf4ebdff47aacfab7876754edeb57bbe1 by Victor Stinner in branch '2.7':
bpo-31067: test_subprocess calls reap_children() (#2931) (#3073)
https://github.com/python/cpython/commit/504939fdf4ebdff47aacfab7876754edeb57bbe1
msg300166 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-08-11 15:14
New changeset f2d769d539279f01a6589dd3a0d5865dd00e13b0 by Victor Stinner in branch '3.6':
bpo-31067: test_subprocess calls reap_children() (#2931) (#3074)
https://github.com/python/cpython/commit/f2d769d539279f01a6589dd3a0d5865dd00e13b0
msg300364 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-08-16 14:18
I made many changes in tests to prevent leaking zombie processes. Let's hope that it was enough to fix this bug. Since the bug occurred randomly, it's hard to say. I close the bug, but will reopen it if the bug occurs again.
History
Date User Action Args
2017-08-16 14:18:58hayposetstatus: open -> closed
resolution: fixed
messages: + msg300364

stage: resolved
2017-08-11 15:14:39hayposetmessages: + msg300166
2017-08-11 15:14:33hayposetmessages: + msg300165
2017-08-11 14:13:21hayposetpull_requests: + pull_request3111
2017-08-11 14:12:28hayposetpull_requests: + pull_request3110
2017-08-11 14:02:49hayposetmessages: + msg300162
2017-07-28 16:00:25hayposetmessages: + msg299401
2017-07-28 14:54:46hayposetpull_requests: + pull_request2982
2017-07-28 14:42:52haypocreate