classification
Title: error: (10035, 'The socket operation could not complete without blocking')
Type: Stage:
Components: Versions: Python 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: dhanlen, draghuram
Priority: normal Keywords:

Created on 2008-04-28 19:44 by dhanlen, last changed 2008-04-28 19:59 by draghuram. This issue is now closed.

Files
File name Uploaded Description Edit
tkinterwork.py dhanlen, 2008-04-28 19:44
Messages (2)
msg65929 - (view) Author: Don Hanlen (dhanlen) Date: 2008-04-28 19:43
IDLE internal error in runcode()
Traceback (most recent call last):
  File "C:\PYTHON25\lib\idlelib\rpc.py", line 235, in asyncqueue
    self.putmessage((seq, request))
  File "C:\PYTHON25\lib\idlelib\rpc.py", line 332, in putmessage
    n = self.sock.send(s[:BUFSIZE])
error: (10035, 'The socket operation could not complete without blocking')

Does this look familiar to anyone?  I can't figure out what to do about
it.  Python 2.5, windoze.  I get it when I execute a Tkinter op that
works elsewhere.

changing this (works):

t = self.b.create_text(
    (point.baseX + 1)*self.checkerSize/2 + fudge,
    y + fudge,
    text = str(point.occupied),
    width = self.checkerSize)

to

t = self.b.create_text(
    (point.baseX + 1)*self.checkerSize/2 + fudge,
    y + fudge,
    text = str(point.occupied),
    font=("Times", str(self.checkerSize/2), "bold"),
    width = self.checkerSize)

for example.  The same code works fine elsewhere.  I thought I'd ask
here before I try (no clue) increasing BUFSIZE in rpc.py?  I'm not crazy
about tinkering with code I have no clue about..

It has been suggested that the problem is competition with IDLE for
tkinter resources.

-- 

don
msg65931 - (view) Author: Raghuram Devarakonda (draghuram) Date: 2008-04-28 19:59
Duplicate of #2710.
History
Date User Action Args
2008-04-28 19:59:18draghuramsetstatus: open -> closed
resolution: duplicate
messages: + msg65931
nosy: + draghuram
2008-04-28 19:44:50dhanlencreate