classification
Title: Distutils' mkpath implementation ignoring the "mode" parameter
Type: behavior Stage: resolved
Components: Distutils Versions: Python 3.2, Python 3.1, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: orsenthil Nosy List: akitada, chromano, eric.araujo, gward, henrique, jafo, orsenthil, pitrou, r.david.murray, tarek
Priority: normal Keywords: easy, patch

Created on 2008-03-04 20:56 by henrique, last changed 2010-09-19 04:21 by orsenthil. This issue is now closed.

Files
File name Uploaded Description Edit
python2.5-distutils_mkpath_filemode.v1.diff henrique, 2008-03-04 20:56 Patch
python-distutils_mkpath_filemode-v2.diff chromano, 2010-09-15 03:31
python-distutils_mkpath_filemode-test-update.diff chromano, 2010-09-19 01:56
Messages (14)
msg63259 - (view) Author: Henrique Romano (henrique) Date: 2008-03-04 20:56
The default value for mkpath's mode parameter is 0777 but it isn't used
at any place; attached is a patch that just pass the parameter to
os.mkdir call, this seems to fix the problem.
msg64177 - (view) Author: Sean Reifschneider (jafo) * (Python committer) Date: 2008-03-20 16:25
This patch looks good to me.  Greg?
msg81180 - (view) Author: Akira Kitada (akitada) Date: 2009-02-04 23:45
Still present in 2.6/3.0
msg107641 - (view) Author: √Čric Araujo (eric.araujo) * (Python committer) Date: 2010-06-12 09:43
Confirmed in trunk (2.7rc2), py3k (3.2), irrelevant for distutils2. Is it too late for 2.7?
msg108887 - (view) Author: Greg Ward (gward) (Python committer) Date: 2010-06-29 02:06
> Is it too late for 2.7?

I have no idea.

It does look as though someone has written unit tests for distutils, so the patch needs a test change too.  Henrique?
msg115052 - (view) Author: Greg Ward (gward) (Python committer) Date: 2010-08-27 02:11
I'm unassigning this since I no longer know how to commit changes to Python.  Sorry, I just haven't kept track over the years, I don't follow python-dev anymore, and I could not find documentation explaining where I should commit what sort of changes.
msg116430 - (view) Author: Henrique Romano (chromano) Date: 2010-09-15 01:28
Patch updated, now it includes test.
msg116433 - (view) Author: Henrique Romano (chromano) Date: 2010-09-15 03:31
Improving tests
msg116678 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2010-09-17 16:42
Fixed for py3k in r84861, release31-maint in r84863 and release27-maint in r84862.

Thanks for patch, Carlos Henrique Romano.
msg116702 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-09-17 18:20
This update appears to be turning the windows buildbots red.  See for example http://www.python.org/dev/buildbot/all/builders/x86 XP-4 3.1/builds/1230/steps/test/logs/stdio.
msg116750 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2010-09-18 03:00
I have skipped the mode tests on windows platforms, as they are not
really applicable.
Lets see the buildbots status and close the bug.
msg116840 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-09-18 23:22
All buildbots are red.
msg116848 - (view) Author: Henrique Romano (chromano) Date: 2010-09-19 01:56
Updating test in order to consider umask, this is supposed to fix buildbot issues.
msg116849 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2010-09-19 04:21
Buildbots are green now after fixing the mode issue in the tests in r84889,r84890,r84891
History
Date User Action Args
2010-09-19 04:21:41orsenthilsetstatus: open -> closed

messages: + msg116849
2010-09-19 01:56:18chromanosetfiles: + python-distutils_mkpath_filemode-test-update.diff

messages: + msg116848
2010-09-18 23:22:01pitrousetassignee: tarek -> orsenthil

messages: + msg116840
nosy: + pitrou
2010-09-18 03:00:08orsenthilsetmessages: + msg116750
2010-09-17 18:20:11r.david.murraysetstatus: closed -> open
nosy: + r.david.murray
messages: + msg116702

2010-09-17 16:42:47orsenthilsetstatus: open -> closed

nosy: + orsenthil
messages: + msg116678

resolution: fixed
stage: test needed -> resolved
2010-09-15 03:31:53chromanosetfiles: + python-distutils_mkpath_filemode-v2.diff

messages: + msg116433
2010-09-15 03:31:14chromanosetfiles: - python-distutils_mkpath_filemode-v1.diff
2010-09-15 01:28:59chromanosetfiles: + python-distutils_mkpath_filemode-v1.diff
nosy: + chromano
messages: + msg116430

2010-08-27 02:11:29gwardsetassignee: gward -> tarek
messages: + msg115052
2010-08-26 20:57:35eric.araujosetversions: + Python 3.2, - Python 2.6, Python 3.0
2010-06-29 02:06:47gwardsetmessages: + msg108887
stage: test needed
2010-06-12 09:43:09eric.araujosetnosy: + eric.araujo
messages: + msg107641
2009-02-04 23:45:07akitadasetnosy: + tarek, akitada
type: resource usage -> behavior
messages: + msg81180
versions: + Python 2.6, Python 3.0, Python 3.1, Python 2.7, - Python 2.5
2008-03-20 16:25:13jafosetnosy: + gward, jafo
messages: + msg64177
priority: normal
assignee: gward
components: + Distutils, - Library (Lib)
keywords: + easy
2008-03-04 20:56:48henriquecreate