classification
Title: clinic.py --converters fails
Type: behavior Stage: resolved
Components: Demos and Tools Versions: Python 3.5, Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: larry Nosy List: larry, python-dev, serhiy.storchaka
Priority: normal Keywords:

Created on 2014-06-01 17:50 by serhiy.storchaka, last changed 2014-06-11 11:35 by larry. This issue is now closed.

Messages (4)
msg219512 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-06-01 17:50
$ ./python Tools/clinic/clinic.py --converters

Legacy converters:
Traceback (most recent call last):
  File "Tools/clinic/clinic.py", line 4199, in <module>
    sys.exit(main(sys.argv[1:]))
  File "Tools/clinic/clinic.py", line 4131, in main
    print('    ' + ' '.join(c for c in legacy if c[0].isupper()))
  File "Tools/clinic/clinic.py", line 4131, in <genexpr>
    print('    ' + ' '.join(c for c in legacy if c[0].isupper()))
IndexError: string index out of range

As I see, the problem is in the self converter which has empty format_unit.
msg220251 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-06-11 10:43
Confirmed.
msg220255 - (view) Author: Roundup Robot (python-dev) Date: 2014-06-11 11:31
New changeset 6b2db7fc17f7 by Larry Hastings in branch '3.4':
Issue #21629: Fix Argument Clinic's "--converters" feature.
http://hg.python.org/cpython/rev/6b2db7fc17f7
msg220257 - (view) Author: Roundup Robot (python-dev) Date: 2014-06-11 11:35
New changeset 8b4b8f5d7321 by Larry Hastings in branch 'default':
Issue #21629: Merge from 3.4.
http://hg.python.org/cpython/rev/8b4b8f5d7321
History
Date User Action Args
2014-06-11 11:35:53larrysetstatus: open -> closed
resolution: fixed
stage: needs patch -> resolved
2014-06-11 11:35:36python-devsetmessages: + msg220257
2014-06-11 11:31:04python-devsetnosy: + python-dev
messages: + msg220255
2014-06-11 10:43:35larrysetassignee: larry
messages: + msg220251
stage: needs patch
2014-06-01 17:50:52serhiy.storchakacreate