classification
Title: Assertion failure in test_readline
Type: crash Stage: needs patch
Components: Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Segfault in UTF-7 incremental decoder
View: 20538
Assigned To: serhiy.storchaka Nosy List: larry, ncoghlan, ned.deily, python-dev, serhiy.storchaka
Priority: release blocker Keywords: 3.4regression, buildbot

Created on 2014-02-07 13:33 by ncoghlan, last changed 2014-02-07 14:13 by ncoghlan. This issue is now closed.

Messages (3)
msg210467 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2014-02-07 13:33
test_readline is consistently failing with an assertion failure in debug builds. I'm going to add a skip for the time being, because I don't know the UnicodeWriter or UTF7 code well enough to guess where the inconsistency may be being introduced.

Relevant extract from faulthandler stack dump:

Current thread 0x00007f83a3e14740 (most recent call first):
  File "/home/ncoghlan/devel/py3k/Lib/codecs.py", line 494 in read
  File "/home/ncoghlan/devel/py3k/Lib/codecs.py", line 548 in readline
  File "/home/ncoghlan/devel/py3k/Lib/test/test_codecs.py", line 168 in test_readline


Relevant extract from gdb trace:

#4  0x00000000004f092f in _PyUnicode_CheckConsistency (
    op='xxx\naaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa', check_content=1)
    at Objects/unicodeobject.c:410
#5  0x0000000000544b75 in _PyUnicodeWriter_Finish (writer=0x7ffffffd7d40) at Objects/unicodeobject.c:13503
#6  0x0000000000510f5b in PyUnicode_DecodeUTF7Stateful (s=0x7fffed18b5b8 "", size=72, 
    errors=0x7ffff19db0e8 "strict", consumed=0x7ffffffd7e48) at Objects/unicodeobject.c:4472
#7  0x0000000000607922 in utf_7_decode (self=<module at remote 0x7ffff197cd58>, 
    args=(b'xxx\naaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa+ICg', 'strict'))
    at ./Modules/_codecsmodule.c:271
msg210468 - (view) Author: Roundup Robot (python-dev) Date: 2014-02-07 13:35
New changeset 2e7c46718b83 by Nick Coghlan in branch 'default':
Issue 20542: Temporarily skip failing test
http://hg.python.org/cpython/rev/2e7c46718b83
msg210469 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-02-07 13:39
Duplicate of Issue20520
History
Date User Action Args
2014-02-07 14:13:22ncoghlansetstatus: open -> closed
superseder: Segfault in UTF-7 incremental decoder
resolution: duplicate
2014-02-07 13:39:16ned.deilysetnosy: + ned.deily
messages: + msg210469
2014-02-07 13:35:02python-devsetnosy: + python-dev
messages: + msg210468
2014-02-07 13:33:32ncoghlancreate