classification
Title: ReadError when open a tarfile for writing
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.4, Python 3.3, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: 20238 Superseder:
Assigned To: serhiy.storchaka Nosy List: georg.brandl, lars.gustaebel, python-dev, serhiy.storchaka
Priority: normal Keywords: patch

Created on 2014-01-13 19:59 by serhiy.storchaka, last changed 2014-01-18 15:19 by serhiy.storchaka. This issue is now closed.

Files
File name Uploaded Description Edit
tarfile_readerror_write_mode.patch serhiy.storchaka, 2014-01-13 19:59 review
Messages (2)
msg208044 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-01-13 19:59
ReadError can be raised when open a tarfile in write mode (e.g. 'w:gz'). Here is a patch wish a test. In additional it rewrites the handling errors in gzopen() which is too complicated now. This complication is possible the cause of bugs #11513 and #20238.
msg208401 - (view) Author: Roundup Robot (python-dev) Date: 2014-01-18 14:31
New changeset 61b6accbca9f by Serhiy Storchaka in branch '2.7':
Issue #20243: TarFile no longer raise ReadError when opened in write mode.
http://hg.python.org/cpython/rev/61b6accbca9f

New changeset 2f3b47b63f91 by Serhiy Storchaka in branch '3.3':
Issue #20243: TarFile no longer raise ReadError when opened in write mode.
http://hg.python.org/cpython/rev/2f3b47b63f91

New changeset 40a5c7547c3d by Serhiy Storchaka in branch 'default':
Issue #20243: TarFile no longer raise ReadError when opened in write mode.
http://hg.python.org/cpython/rev/40a5c7547c3d
History
Date User Action Args
2014-01-18 15:19:15serhiy.storchakasetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2014-01-18 14:31:41python-devsetnosy: + python-dev
messages: + msg208401
2014-01-13 20:27:08serhiy.storchakalinkissue20244 dependencies
2014-01-13 20:01:41serhiy.storchakasetdependencies: + Incomplete gzip output with tarfile.open(fileobj=..., mode="w:gz")
2014-01-13 19:59:44serhiy.storchakacreate