classification
Title: Better estimated memory requirements for bigmem tests
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.4, Python 3.3, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: serhiy.storchaka Nosy List: ezio.melotti, michael.foord, pitrou, python-dev, serhiy.storchaka
Priority: normal Keywords: patch

Created on 2013-12-04 19:30 by serhiy.storchaka, last changed 2014-01-11 10:45 by serhiy.storchaka. This issue is now closed.

Files
File name Uploaded Description Edit
bigmem_tests.patch serhiy.storchaka, 2013-12-04 19:30 review
Messages (5)
msg205236 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-12-04 19:30
Some bigmem tests actually consume much more memory than declare. This can cause swapping and too long time of test run. Here is a patch which improves estimates.
msg205238 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2013-12-04 19:32
Why did you compute those estimates? When coming up with factors such as 3.3 or 3.57 (!), it would be nice to add a comment to explain the reasoning.

(otherwise, thanks a lot for doing this)
msg205239 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-12-04 19:42
These are experimental values. I hacked tests and ran them with less sizes (using `ulimit -v` to hard limit memory size). And then I had approximated measured values.

On Windows values can be larger (due different memory management).
msg207852 - (view) Author: Roundup Robot (python-dev) Date: 2014-01-10 11:41
New changeset aee672ba9c38 by Serhiy Storchaka in branch '2.7':
Issue #19886: Use better estimated memory requirements for bigmem tests.
http://hg.python.org/cpython/rev/aee672ba9c38

New changeset 2ca26065fb00 by Serhiy Storchaka in branch '3.3':
Issue #19886: Use better estimated memory requirements for bigmem tests.
http://hg.python.org/cpython/rev/2ca26065fb00

New changeset fff1455e1147 by Serhiy Storchaka in branch 'default':
Issue #19886: Use better estimated memory requirements for bigmem tests.
http://hg.python.org/cpython/rev/fff1455e1147
msg207855 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-01-10 11:50
I never decreased requirements, so these changes shouldn't cause regressions.
History
Date User Action Args
2014-01-11 10:45:56serhiy.storchakasetstatus: open -> closed
stage: commit review -> resolved
resolution: fixed
versions: + Python 2.7
2014-01-10 11:50:32serhiy.storchakasetassignee: serhiy.storchaka
messages: + msg207855
stage: patch review -> commit review
2014-01-10 11:42:00python-devsetnosy: + python-dev
messages: + msg207852
2013-12-04 19:42:21serhiy.storchakasetmessages: + msg205239
2013-12-04 19:32:16pitrousetmessages: + msg205238
2013-12-04 19:30:13serhiy.storchakacreate