classification
Title: test_wave failing on PPC64 Linux
Type: behavior Stage: resolved
Components: Library (Lib), Tests Versions: Python 3.4, Python 3.3, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: serhiy.storchaka Nosy List: David.Edelsohn, pitrou, python-dev, serhiy.storchaka
Priority: normal Keywords: patch

Created on 2013-10-17 03:38 by David.Edelsohn, last changed 2013-10-18 15:26 by David.Edelsohn. This issue is now closed.

Files
File name Uploaded Description Edit
wave_ppc64.patch serhiy.storchaka, 2013-10-17 18:55 review
Messages (11)
msg200116 - (view) Author: Roundup Robot (python-dev) Date: 2013-10-17 09:52
New changeset 73dad296c483 by Serhiy Storchaka in branch '2.7':
Issue 19276: Fix tests for wave files on big-endian platforms.
http://hg.python.org/cpython/rev/73dad296c483

New changeset 236884b40a2d by Serhiy Storchaka in branch '3.3':
Issue 19276: Fix tests for wave files on big-endian platforms.
http://hg.python.org/cpython/rev/236884b40a2d

New changeset 8bdf5328c55b by Serhiy Storchaka in branch 'default':
Issue 19276: Fix tests for wave files on big-endian platforms.
http://hg.python.org/cpython/rev/8bdf5328c55b
msg200127 - (view) Author: David Edelsohn (David.Edelsohn) * Date: 2013-10-17 13:55
The patch does not appear to fix the tests for wave on big-endian PPC64 Linux.
msg200130 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-10-17 14:31
It fixed a bug in wave tests, but not a bug in the wave module. I'm working on this.
msg200153 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-10-17 18:55
What are array.array('l').itemsize and array.array('i').itemsize on PPC64 Linux?

I suppose that this patch should fix the wave module on 64-bit platforms.
msg200155 - (view) Author: David Edelsohn (David.Edelsohn) * Date: 2013-10-17 19:06
>>> import array
>>> print array.array('l').itemsize
8
>>> print array.array('i').itemsize
4
msg200158 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-10-17 19:59
Thank you David. I suspected this.
msg200160 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2013-10-17 20:01
For the record, why would this patch fix the issue? test_wave works fine under other 64-bit platforms.
msg200162 - (view) Author: Roundup Robot (python-dev) Date: 2013-10-17 20:05
New changeset 9d2605f24a86 by Serhiy Storchaka in branch '2.7':
Issue #19276: Fixed the wave module on 64-bit big-endian platforms.
http://hg.python.org/cpython/rev/9d2605f24a86

New changeset a1a4a527c699 by Serhiy Storchaka in branch '3.3':
Issue #19276: Fixed the wave module on 64-bit big-endian platforms.
http://hg.python.org/cpython/rev/a1a4a527c699

New changeset 7e8ad3084891 by Serhiy Storchaka in branch 'default':
Issue #19276: Fixed the wave module on 64-bit big-endian platforms.
http://hg.python.org/cpython/rev/7e8ad3084891
msg200164 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-10-17 20:09
Perhaps other 64-bit platforms are little-endian?
msg200173 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-10-17 22:56
Fixed. Thank you David for your report.
msg200273 - (view) Author: David Edelsohn (David.Edelsohn) * Date: 2013-10-18 15:26
Thanks!
History
Date User Action Args
2013-10-18 15:26:51David.Edelsohnsetmessages: + msg200273
2013-10-17 22:56:08serhiy.storchakasetstatus: open -> closed
resolution: fixed
messages: + msg200173

stage: patch review -> resolved
2013-10-17 20:09:35serhiy.storchakasetmessages: + msg200164
2013-10-17 20:05:51python-devsetmessages: + msg200162
2013-10-17 20:01:49pitrousetnosy: + pitrou
messages: + msg200160
2013-10-17 19:59:05serhiy.storchakasetmessages: + msg200158
2013-10-17 19:06:58David.Edelsohnsetmessages: + msg200155
2013-10-17 18:55:50serhiy.storchakasetstage: needs patch -> patch review
2013-10-17 18:55:41serhiy.storchakasetfiles: + wave_ppc64.patch
keywords: + patch
messages: + msg200153

stage: needs patch
2013-10-17 14:31:27serhiy.storchakasetmessages: + msg200130
2013-10-17 13:55:03David.Edelsohnsetmessages: + msg200127
2013-10-17 09:52:32python-devsetnosy: + python-dev
messages: + msg200116
2013-10-17 09:37:18serhiy.storchakasetassignee: serhiy.storchaka

nosy: + serhiy.storchaka
components: + Library (Lib), Tests, - Extension Modules
versions: + Python 2.7, - Python 3.5
2013-10-17 03:38:02David.Edelsohncreate