classification
Title: Make on Solaris 11 x64 with OracleStudio12.3 failed
Type: compile error Stage: resolved
Components: Build Versions: Python 3.4, Python 3.3, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, christian.heimes, jcea, podlipnik
Priority: normal Keywords:

Created on 2013-09-19 07:02 by podlipnik, last changed 2013-12-16 18:39 by christian.heimes. This issue is now closed.

Messages (3)
msg198042 - (view) Author: Borut Podlipnik (podlipnik) Date: 2013-09-19 07:02
# make
CC -c  -g -DNDEBUG -O  -I. -IInclude -I./Include  -DPy_BUILD_CORE -o Modules/python.o ./Modules/python.c
CC -c  -g -DNDEBUG -O  -I. -IInclude -I./Include  -DPy_BUILD_CORE -o Parser/acceler.o Parser/acceler.c
CC -c  -g -DNDEBUG -O  -I. -IInclude -I./Include  -DPy_BUILD_CORE -o Parser/grammar1.o Parser/grammar1.c
"Parser/grammar1.c", line 39: Warning: String literal converted to char* in initialization.
1 Warning(s) detected.
CC -c  -g -DNDEBUG -O  -I. -IInclude -I./Include  -DPy_BUILD_CORE -o Parser/listnode.o Parser/listnode.c
CC -c  -g -DNDEBUG -O  -I. -IInclude -I./Include  -DPy_BUILD_CORE -o Parser/node.o Parser/node.c
CC -c  -g -DNDEBUG -O  -I. -IInclude -I./Include  -DPy_BUILD_CORE -o Parser/parser.o Parser/parser.c
CC -c  -g -DNDEBUG -O  -I. -IInclude -I./Include  -DPy_BUILD_CORE -o Parser/parsetok.o Parser/parsetok.c
"Parser/parsetok.c", line 250: Error: Cannot assign void* to char*.
1 Error(s) detected.
*** Error code 2
make: Fatal error: Command failed for target `Parser/parsetok.o'
msg198138 - (view) Author: Borut Podlipnik (podlipnik) Date: 2013-09-20 09:41
Using c compiler instead of c++ compiler, solved the problem:
setenv CC cc 
setenv CXX cc 
setenv LD_LIBRARY_PATH "/opt/solarisstudio12.3/lib:/usr/lib"

# ./configure --without-gcc --with-cxx-main=CC --prefix=/opt/python
# make
# make test

However, make test failed:
….
352 tests OK.
3 tests failed:
    test_ctypes test_posix test_uuid
1 test altered the execution environment:
    test_distutils
36 tests skipped:
    test_aepack test_al test_applesingle test_bsddb185 test_bsddb3
    test_cd test_cl test_codecmaps_cn test_codecmaps_hk
    test_codecmaps_jp test_codecmaps_kr test_codecmaps_tw test_curses
    test_epoll test_gdb test_gl test_imgfile test_kqueue
    test_linuxaudiodev test_macos test_macostools test_msilib
    test_ossaudiodev test_scriptpackages test_smtpnet
    test_socketserver test_startfile test_sunaudiodev test_timeout
    test_tk test_ttk_guionly test_urllib2net test_urllibnet
    test_winreg test_winsound test_zipfile64
4 skips unexpected on sunos5:
    test_gdb test_sunaudiodev test_tk test_ttk_guionly
*** Error code 1
make: Fatal error: Command failed for target `test'
# 

# ./python Lib/test/regrtest.py -v test_uuid
== CPython 2.7.5 (default, Sep 19 2013, 12:00:58) [C]
==   Solaris-2.11-i86pc-i386-32bit-ELF little-endian
==   /home/borut/admin/python/Python-2.7.5/build/test_python_14443
Testing with flags: sys.flags(debug=0, py3k_warning=0, division_warning=0, division_new=0, inspect=0, interactive=0, optimize=0, dont_write_bytecode=0, no_user_site=0, no_site=0, ignore_environment=0, tabcheck=0, verbose=0, unicode=0, bytes_warning=0, hash_randomization=0)
test_uuid
testIssue8621 (test.test_uuid.TestUUID) ... ok
test_UUID (test.test_uuid.TestUUID) ... ok
test_exceptions (test.test_uuid.TestUUID) ... ok
test_getnode (test.test_uuid.TestUUID) ... ok
test_ifconfig_getnode (test.test_uuid.TestUUID) ... ok
test_ipconfig_getnode (test.test_uuid.TestUUID) ... ok
test_netbios_getnode (test.test_uuid.TestUUID) ... ok
test_random_getnode (test.test_uuid.TestUUID) ... ok
test_unixdll_getnode (test.test_uuid.TestUUID) ... ok
test_uuid1 (test.test_uuid.TestUUID) ... ok
test_uuid3 (test.test_uuid.TestUUID) ... ok
test_uuid4 (test.test_uuid.TestUUID) ... FAIL
test_uuid5 (test.test_uuid.TestUUID) ... ok
test_windll_getnode (test.test_uuid.TestUUID) ... ok

======================================================================
FAIL: test_uuid4 (test.test_uuid.TestUUID)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_uuid.py", line 422, in test_uuid4
    equal(u.variant, uuid.RFC_4122)
AssertionError: 'reserved for future definition' != 'specified in RFC 4122'

----------------------------------------------------------------------
Ran 14 tests in 0.166s

FAILED (failures=1)
test test_uuid failed -- Traceback (most recent call last):
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_uuid.py", line 422, in test_uuid4
    equal(u.variant, uuid.RFC_4122)
AssertionError: 'reserved for future definition' != 'specified in RFC 4122'

1 test failed:
    test_uuid
# 

# ./python Lib/test/regrtest.py -v test_ctypes
== CPython 2.7.5 (default, Sep 19 2013, 12:00:58) [C]
==   Solaris-2.11-i86pc-i386-32bit-ELF little-endian
==   /home/borut/admin/python/Python-2.7.5/build/test_python_14454
Testing with flags: sys.flags(debug=0, py3k_warning=0, division_warning=0, division_new=0, inspect=0, interactive=0, optimize=0, dont_write_bytecode=0, no_user_site=0, no_site=0, ignore_environment=0, tabcheck=0, verbose=0, unicode=0, bytes_warning=0, hash_randomization=0)
test_ctypes
test_incomplete_example (ctypes.test.test_incomplete.MyTestCase) ... ok
test_native (ctypes.test.test_unaligned_structures.TestStructures) ... ok
test_swapped (ctypes.test.test_unaligned_structures.TestStructures) ... ok


======================================================================
FAIL: test_ints (ctypes.test.test_bitfields.C_Test)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/borut/admin/python/Python-2.7.5/Lib/ctypes/test/test_bitfields.py", line 40, in test_ints
    self.assertEqual((name, i, getattr(b, name)), (name, i, func(byref(b), name)))
AssertionError: Tuples differ: ('A', 1, -1) != ('A', 1, 1)

First differing element 2:
-1
1

- ('A', 1, -1)
?          -

+ ('A', 1, 1)

======================================================================
FAIL: test_shorts (ctypes.test.test_bitfields.C_Test)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/borut/admin/python/Python-2.7.5/Lib/ctypes/test/test_bitfields.py", line 47, in test_shorts
    self.assertEqual((name, i, getattr(b, name)), (name, i, func(byref(b), name)))
AssertionError: Tuples differ: ('R', 32, -32) != ('R', 32, 32)

First differing element 2:
-32
32

- ('R', 32, -32)
?           -

+ ('R', 32, 32)

----------------------------------------------------------------------
Ran 345 tests in 0.341s

FAILED (failures=2, skipped=1)
test test_ctypes failed -- multiple errors occurred
1 test failed:
    test_ctypes
# 

# ./python Lib/test/regrtest.py -v test_posix
== CPython 2.7.5 (default, Sep 19 2013, 12:00:58) [C]
==   Solaris-2.11-i86pc-i386-32bit-ELF little-endian
==   /home/borut/admin/python/Python-2.7.5/build/test_python_14477
Testing with flags: sys.flags(debug=0, py3k_warning=0, division_warning=0, division_new=0, inspect=0, interactive=0, optimize=0, dont_write_bytecode=0, no_user_site=0, no_site=0, ignore_environment=0, tabcheck=0, verbose=0, unicode=0, bytes_warning=0, hash_randomization=0)
test_posix
testNoArgFunctions (test.test_posix.PosixTester) ... ok
test_access (test.test_posix.PosixTester) ... ok
test_chdir (test.test_posix.PosixTester) ... ok
test_chflags (test.test_posix.PosixTester) ... skipped 'test needs os.chflags()'
test_chown (test.test_posix.PosixTester) ... FAIL
test_confstr (test.test_posix.PosixTester) ... ok
test_dup (test.test_posix.PosixTester) ... ok
test_dup2 (test.test_posix.PosixTester) ... ok
test_fchown (test.test_posix.PosixTester) ... FAIL
test_fdopen (test.test_posix.PosixTester) ... ok
test_fstat (test.test_posix.PosixTester) ... ok
test_fstatvfs (test.test_posix.PosixTester) ... ok
test_ftruncate (test.test_posix.PosixTester) ... ok
test_getcwd_long_pathnames (test.test_posix.PosixTester) ... ok
test_getgroups (test.test_posix.PosixTester) ... ok
test_initgroups (test.test_posix.PosixTester) ... ok
test_lchflags_regular_file (test.test_posix.PosixTester) ... skipped 'test needs os.lchflags()'
test_lchflags_symlink (test.test_posix.PosixTester) ... skipped 'test needs os.lchflags()'
test_lchown (test.test_posix.PosixTester) ... FAIL
test_lsdir (test.test_posix.PosixTester) ... ok
test_osexlock (test.test_posix.PosixTester) ... ok
test_osshlock (test.test_posix.PosixTester) ... ok
test_pipe (test.test_posix.PosixTester) ... ok
test_stat (test.test_posix.PosixTester) ... ok
test_statvfs (test.test_posix.PosixTester) ... ok
test_strerror (test.test_posix.PosixTester) ... ok
test_tempnam (test.test_posix.PosixTester) ... ok
test_tmpfile (test.test_posix.PosixTester) ... ok
test_umask (test.test_posix.PosixTester) ... ok
test_utime (test.test_posix.PosixTester) ... ok
test_initgroups (test.test_posix.PosixGroupsTester) ... ok
test_setgroups (test.test_posix.PosixGroupsTester) ... ok

======================================================================
FAIL: test_chown (test.test_posix.PosixTester)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_posix.py", line 293, in test_chown
    getattr(posix, 'stat', None))
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_posix.py", line 258, in _test_all_chown_common
    check_stat(big_value, big_value)
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_posix.py", line 230, in check_stat
    self.assertEqual(stat.st_uid, uid)
AssertionError: 60001 != 2147483648L

======================================================================
FAIL: test_fchown (test.test_posix.PosixTester)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_posix.py", line 304, in test_fchown
    getattr(posix, 'fstat', None))
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_posix.py", line 258, in _test_all_chown_common
    check_stat(big_value, big_value)
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_posix.py", line 230, in check_stat
    self.assertEqual(stat.st_uid, uid)
AssertionError: 60001 != 2147483648L

======================================================================
FAIL: test_lchown (test.test_posix.PosixTester)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_posix.py", line 314, in test_lchown
    getattr(posix, 'lstat', None))
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_posix.py", line 258, in _test_all_chown_common
    check_stat(big_value, big_value)
  File "/home/borut/admin/python/Python-2.7.5/Lib/test/test_posix.py", line 230, in check_stat
    self.assertEqual(stat.st_uid, uid)
AssertionError: 60001 != 2147483648L

----------------------------------------------------------------------
Ran 32 tests in 0.019s

FAILED (failures=3, skipped=3)
test test_posix failed -- multiple errors occurred
1 test failed:
    test_posix
#
msg206343 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2013-12-16 18:39
Thanks for the report. This is a duplicate of issue #16733. I'm closing this bug as duplicated.
History
Date User Action Args
2013-12-16 18:39:13christian.heimessetstatus: open -> closed

versions: + Python 3.3, Python 3.4
nosy: + christian.heimes

messages: + msg206343
resolution: duplicate
stage: resolved
2013-09-20 17:14:38ned.deilysetnosy: + jcea
2013-09-20 09:41:33podlipniksetmessages: + msg198138
2013-09-20 00:39:04ned.deilysetnosy: + benjamin.peterson
2013-09-19 07:02:59podlipnikcreate