classification
Title: Invalid charset in HTML pages inside documentation in CHM format
Type: behavior Stage:
Components: Documentation Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: docs@python, ezio.melotti, georg.brandl, grv87, serhiy.storchaka
Priority: normal Keywords:

Created on 2013-08-14 11:59 by grv87, last changed 2013-10-13 18:08 by georg.brandl. This issue is now closed.

Messages (2)
msg195136 - (view) Author: Basil Peace (grv87) Date: 2013-08-14 11:59
HTML pages inside CHM documentation use the following tag to set applied character set:
    <meta http-equiv="Content-Type" content="text/html; charset=iso8859_1" />

`iso8859_1` is neither valid character set according to IANA registry nor is recognized by most browsers (I've checked IE, Firefox and Opera).

This isn't notable for text in English. But, in `Python Standard Library` in section `4.7.1 String Methods` there is a documentation for str.casefold(). This paragraph contains German letter `ß`.
Without defined character set this letter can be displayed wrongly, depending on user's regional settings. In my Russian I see in CHM `Я`. Firefox displays it as `�`.

Fix of charset to `ISO-8859-1` could resolve the problem.

P.S. Use of UTF-8 may be more convenient for preventing future errors.
msg195415 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2013-08-16 20:39
This is a problem with Sphinx and should be reported upstream.
These encondings are defined in the htmlhelp builder and they are recognized by Python, but indeed they shouldn't end up in the meta tag.
History
Date User Action Args
2013-10-13 18:08:24georg.brandlsetstatus: pending -> closed
resolution: not a bug
2013-08-16 20:39:00ezio.melottisetstatus: open -> pending

nosy: + georg.brandl, ezio.melotti
messages: + msg195415

assignee: docs@python -> georg.brandl
type: behavior
2013-08-14 12:44:02serhiy.storchakasetnosy: + serhiy.storchaka
2013-08-14 11:59:06grv87create