classification
Title: can not open idle in python 2.7.3
Type: behavior Stage:
Components: IDLE, Windows Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: hayeswu, kbk, roger.serwy, terry.reedy
Priority: normal Keywords:

Created on 2013-02-18 08:40 by hayeswu, last changed 2013-08-30 22:16 by terry.reedy. This issue is now closed.

Messages (2)
msg182306 - (view) Author: william wu (hayeswu) Date: 2013-02-18 08:40
I install python 2.7 in windows xp 32bit. 
I try to open idle using "C:\Python27>python.exe Lib\idlelib\idle.py", But return error as following:

Traceback (most recent call last):
  File "Lib\idlelib\idle.py", line 11, in <module>
    idlelib.PyShell.main()
  File "C:\Python27\Lib\idlelib\PyShell.py", line 1421, in main
    shell = flist.open_shell()
  File "C:\Python27\Lib\idlelib\PyShell.py", line 289, in open_shell
    if not self.pyshell.begin():
  File "C:\Python27\Lib\idlelib\PyShell.py", line 1009, in begin
    client = self.interp.start_subprocess()
  File "C:\Python27\Lib\idlelib\PyShell.py", line 402, in start_subprocess
    self.port = self.rpcclt.listening_sock.getsockname()[1]
  File "C:\Python27\Lib\socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
socket.gaierror: [Errno 10104] getaddrinfo failed
it's fine if using "C:\Python27>python.exe Lib\idlelib\idle.py -n". it doesn't work after i try to close firewall.
msg191226 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-06-15 19:14
This is probably a duplicate of other issues. But please try with the newest 2.7.5.
History
Date User Action Args
2013-08-30 22:16:59terry.reedysetstatus: open -> closed
resolution: duplicate
2013-06-15 19:14:58terry.reedysetmessages: + msg191226
2013-02-22 18:26:11terry.reedysetnosy: + terry.reedy, roger.serwy
2013-02-18 08:53:24serhiy.storchakasetnosy: + kbk
type: behavior
components: + IDLE
2013-02-18 08:40:30hayeswucreate