classification
Title: Python IDLE GUI does not open in Ubuntu 12.04
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.4, Python 3.2, Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: serhiy.storchaka Nosy List: python-dev, rjs.swarnkar, serhiy.storchaka
Priority: normal Keywords: 3.2regression, patch

Created on 2013-02-03 14:37 by rjs.swarnkar, last changed 2013-02-07 13:35 by serhiy.storchaka. This issue is now closed.

Files
File name Uploaded Description Edit
idle_nonstrict_config.patch serhiy.storchaka, 2013-02-04 12:49 review
Messages (9)
msg181271 - (view) Author: Swarnkar Rajesh (rjs.swarnkar) Date: 2013-02-03 14:37
[Hello all. Just registered to ask this.]

I insatlled python 3.2 from Ubuntu Software Center. 
It created python Icon in launcher as expected. 

It was working fine until i customized the IDLE theme. I edited the 
config-highlight.cfg found in /home/user/.idlerc (hidden) directory. 
I copy pasted desert color theme into this file and pressed save.(I perfectly edited file with leaving one newline at end. So it is not issue with editing i believe.) 

Then i closed the editor. When i tried running by clicking 'IDLE (Using Python 3.2)' in Ubuntu launcher, it glows for a while then nothing shows up. 
I could see a process name python running in system monitor, but no IDLE window.

I tried these issues : 
4049
15998
8099
7265

But all these issues are related to windows OS. 
I tried follwing the similar instruction but i see three directories in /usr/lib/ as python2.7, python3 and python3.2. I am stuck at this point. So i did not choose to proceed. :S

Can you please see into it? Thank you.
msg181282 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-02-03 16:49
Can you please provide your config-highlight.cfg?
msg181318 - (view) Author: Swarnkar Rajesh (rjs.swarnkar) Date: 2013-02-04 12:17
Sure, Here it is:

[Rajesh_Python_Settings]
definition-foreground = #86deff
error-foreground = #ff1c1c
normal-foreground = #ffffff
keyword-foreground = #fff900
hilite-foreground = #000000
comment-background = #511633
hit-foreground = #ffffff
builtin-background = #511633
stdout-foreground = #efefef
cursor-foreground = #fffff5
string-background = #511633
break-background = #ffff55
comment-foreground = #997678
hilite-background = gray
definition-background = #511633
stderr-background = #511633
hit-background = #000000
console-foreground = #2cbbff
normal-background = #511633
builtin-foreground = #f4cec6
stdout-background = #511630
console-background = #511644
stderr-foreground = #ff5900
keyword-background = #511633
string-foreground = #00e05b
break-foreground = black
error-background = #311634
cursor-foreground = black

[Obsidian]
definition-foreground = #678CB1
error-foreground = #FF0000
string-background = #293134
keyword-foreground = #93C763
normal-foreground = #E0E2E4
comment-background = #293134
hit-foreground = #E0E2E4
builtin-background = #293134
stdout-foreground = #678CB1
cursor-foreground = #E0E2E4
break-background = #293134
comment-foreground = #66747B
hilite-background = #2F393C
hilite-foreground = #E0E2E4
definition-background = #293134
stderr-background = #293134
hit-background = #000000
console-foreground = #E0E2E4
normal-background = #293134
builtin-foreground = #E0E2E4
stdout-background = #293134
console-background = #293134
stderr-foreground = #FB0000
keyword-background = #293134
string-foreground = #EC7600
break-foreground = #E0E2E4
error-background = #293134

The erlier one is my own custom setting, i edited it on idle and saved as custom theme. Also to mention later one theme added via text editor from this site: ramdump(dot)com/2011/08/04/obsidian-theme-for-idle/. 
Thanks.
msg181320 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-02-04 12:38
Run IDLE from command line and you will see:

configparser.DuplicateOptionError: While reading from .../.idlerc/config-highlight.cfg [line 29]: option 'cursor-foreground' in section 'Rajesh_Python_Settings' already exists

Your configuration is wrong. Just remove duplicated option 'cursor-foreground' (and other duplications if they exist).

However 2.7 and 3.1 are tolerant for this. This is an IDLE bug, a regression in 3.2.
msg181321 - (view) Author: Swarnkar Rajesh (rjs.swarnkar) Date: 2013-02-04 12:46
Thank you Serhiy Storchaka.
It worked well. I did not noticed that. 
Thanks again.
msg181322 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-02-04 12:49
ConfigParser is more strong by default since 3.2. Here is a simple patch which made IDLE more tolerant for such kind of user errors.
msg181325 - (view) Author: Swarnkar Rajesh (rjs.swarnkar) Date: 2013-02-04 13:03
How can i install this patch?
msg181606 - (view) Author: Roundup Robot (python-dev) Date: 2013-02-07 13:27
New changeset cf98766f464e by Serhiy Storchaka in branch '3.2':
Issue #17114: IDLE now uses non-strict config parser.
http://hg.python.org/cpython/rev/cf98766f464e

New changeset c2ed79fbb9c6 by Serhiy Storchaka in branch '3.3':
Issue #17114: IDLE now uses non-strict config parser.
http://hg.python.org/cpython/rev/c2ed79fbb9c6

New changeset 877fae8d6f5b by Serhiy Storchaka in branch 'default':
Issue #17114: IDLE now uses non-strict config parser.
http://hg.python.org/cpython/rev/877fae8d6f5b
msg181607 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-02-07 13:35
Just wait a few weeks to release of 3.2.4 and it's appearance in your distribution.
History
Date User Action Args
2013-02-07 13:35:24serhiy.storchakasetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2013-02-07 13:35:03serhiy.storchakasetmessages: + msg181607
2013-02-07 13:27:14python-devsetnosy: + python-dev
messages: + msg181606
2013-02-04 13:03:24rjs.swarnkarsetmessages: + msg181325
2013-02-04 12:49:36serhiy.storchakasetfiles: + idle_nonstrict_config.patch
messages: + msg181322

assignee: serhiy.storchaka
keywords: + patch
stage: needs patch -> patch review
2013-02-04 12:46:12rjs.swarnkarsetmessages: + msg181321
2013-02-04 12:39:00serhiy.storchakasetversions: + Python 3.3, Python 3.4
messages: + msg181320

keywords: + 3.2regression
type: behavior
stage: needs patch
2013-02-04 12:17:12rjs.swarnkarsetmessages: + msg181318
2013-02-03 16:49:52serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg181282
2013-02-03 14:37:13rjs.swarnkarcreate