classification
Title: Fix test discovery for test_codecs.py
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.4, Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ezio.melotti Nosy List: brett.cannon, ezio.melotti, python-dev, zach.ware
Priority: normal Keywords: patch

Created on 2013-01-10 16:39 by zach.ware, last changed 2013-01-11 04:10 by ezio.melotti. This issue is now closed.

Files
File name Uploaded Description Edit
test_codecs_discovery.diff zach.ware, 2013-01-10 16:39 test_codecs.py fix, version 1 review
Messages (4)
msg179571 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2013-01-10 16:39
Here's the fix for test_codecs.py, I believe.  I had a few headaches trying to get this patch created without changing some of the characters or adding a BOM to the file, and at one point the test was failing for no apparent reason.  This version of the patch seems to work on my machine, though.
msg179620 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2013-01-11 03:38
FTR, the failure you saw while switching to unittest.main() seems to be caused by a broken test that wasn't run.  Unittest test discovery simply revealed the problem -- I'm working on it.
msg179622 - (view) Author: Roundup Robot (python-dev) Date: 2013-01-11 04:06
New changeset 11e7d0936fa2 by Ezio Melotti in branch '3.3':
#16918: test_codecs now works with unittest test discovery. Patch by Zachary Ware.
http://hg.python.org/cpython/rev/11e7d0936fa2

New changeset 02180599a99f by Ezio Melotti in branch 'default':
#16918: merge with 3.3.
http://hg.python.org/cpython/rev/02180599a99f
msg179623 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2013-01-11 04:10
Fixed, thanks for the patch!
Apparently the broken test was ported from Python 2 to Python 3 in 4747ef9640ae (back in the SVN days), but the name of the test class was not added to the list of tests in test_main.  Without the test class in the list, the test was not run, so no one noticed it was broken (it was a simply bytes/unicode issue).  I now re-enabled it and fix it.
History
Date User Action Args
2013-01-11 04:10:57ezio.melottisetstatus: open -> closed
resolution: fixed
messages: + msg179623

stage: patch review -> resolved
2013-01-11 04:06:12python-devsetnosy: + python-dev
messages: + msg179622
2013-01-11 03:38:11ezio.melottisetmessages: + msg179620
2013-01-10 16:59:05ezio.melottisetassignee: ezio.melotti
stage: patch review
2013-01-10 16:39:57zach.warecreate