classification
Title: pythonw.exe crashes when run in one particular account on Windows XP Pro
Type: crash Stage:
Components: IDLE, Installation, Interpreter Core, Windows Versions: Python 2.5
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: kbk Nosy List: Mr.E, kbk
Priority: normal Keywords:

Created on 2007-12-20 16:04 by Mr.E, last changed 2007-12-24 20:26 by kbk. This issue is now closed.

Messages (4)
msg58896 - (view) Author: Eric Moyer (Mr.E) Date: 2007-12-20 16:04
I installed the python-2.5.1.msi stable package from the python.org
website using a super-user account on my system.  I installed "for all
users" and used the default location and chose to install everything,
not omitting any component.

After installation, I moved the startup menu folder to be a sub-menu of
my Programming startup menu folder.  Then I ran IDLE and typed in a few
recipes from the itertools package to ensure that everything worked. 
Then I logged out and logged back in with my normal user account.  In my
normal account, the three startup menu items "IDLE (Python GUI)",
"Module Docs", and "Python (command line)" all crash.  The first two
crash with a window titled "pythonw.exe - Application Error".  The last
one opens an empty command prompt window before dying with a window
titled "python.exe - Application Error".  All the error windows have the
text, "The application failed to initialize properly (0xc0000022). Click
on OK to terminate the application"

Since it works when I am logged in as an administrator, my guess is that
the error has something to do with windows security.
msg58901 - (view) Author: Eric Moyer (Mr.E) Date: 2007-12-20 16:46
I tried adding my normal account to the administrators group and that
did not fix the problem.

And my system:
I am running fully patched Windows XP professional SP 2 on a Presario
V2000 (AMD Turion 64 ML-37 with 480 MB ram (the other 32 MB RAM is used
by the video card))
msg58905 - (view) Author: Eric Moyer (Mr.E) Date: 2007-12-20 17:26
I tried rolling back the computer and installing it on my normal account
with added super-user privileges and though the install succeeded, I
still couldn't run it.  However, the normal super-user could run it just
fine.

Looks like this is some weird misconfiguration on my normal account. 
I'd delete this report if I could now, because it looks like this bug
will be irreproducible.
msg58987 - (view) Author: Kurt B. Kaiser (kbk) * (Python committer) Date: 2007-12-24 20:26
Thanks for the report.  Please reopen it if you come up 
with further confimation.
History
Date User Action Args
2007-12-24 20:26:54kbksetstatus: open -> closed
assignee: kbk
messages: + msg58987
resolution: works for me
nosy: + kbk
2007-12-20 17:26:40Mr.Esetmessages: + msg58905
title: pythonw.exe crashes when run as non-installer on Windows XP Pro -> pythonw.exe crashes when run in one particular account on Windows XP Pro
2007-12-20 16:46:01Mr.Esetmessages: + msg58901
title: pythonw.exe crashes when run as non-administrator on Windows XP Pro -> pythonw.exe crashes when run as non-installer on Windows XP Pro
2007-12-20 16:04:19Mr.Ecreate