classification
Title: test_posix.test_getgroups fails on some systems
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.4, Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, georg.brandl, ned.deily, python-dev, rosslagerwall
Priority: normal Keywords: patch

Created on 2012-12-16 14:05 by rosslagerwall, last changed 2013-02-03 01:23 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
issue16698_27.patch ned.deily, 2013-02-02 22:34
Messages (6)
msg177601 - (view) Author: Ross Lagerwall (rosslagerwall) (Python committer) Date: 2012-12-16 14:05
test_posix.test_getgroups() fails on some systems:

http://buildbot.python.org/all/builders/AMD64%20Mountain%20Lion%20%5BSB%5D%203.2

This could be related to #16661.
msg177630 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-12-16 21:34
The test failure on OS X is likely an instance of the platform limitation documented in issue10433.
msg181224 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-02-02 22:34
The problem is as documented for issue10433: http://docs.python.org/2/library/os.html#os.getgroups

Here's a patch that skips the failing test when Python is built on OS X with a deployment target less than 10.6.  Currently on releases prior to 3.3.0, the build deployment target defaults to 10.5 or earlier unless it is explicitly overridden at configure time with MACOSX_DEPLOYMENT_TARGET (Issue11485).  The patch seems to work OK on 2.7.  I'm about to test with 3.2 and later.
msg181227 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-02-02 23:01
It seems to work on 3.x as well.  Since it is minimally invasive and should help to clean up the OS X buildbots, I'm going to push the fix now and keep an eye on the buildbots.
msg181228 - (view) Author: Roundup Robot (python-dev) Date: 2013-02-02 23:14
New changeset c37ac05119ff by Ned Deily in branch '2.7':
Issue #16698: Skip posix test_getgroups when built with OS X
http://hg.python.org/cpython/rev/c37ac05119ff

New changeset 6c9f4c22fd81 by Ned Deily in branch '3.2':
Issue #16698: Skip posix test_getgroups when built with OS X
http://hg.python.org/cpython/rev/6c9f4c22fd81

New changeset 3653d8174b0b by Ned Deily in branch '3.3':
Issue #16698: merge from 3.2
http://hg.python.org/cpython/rev/3653d8174b0b

New changeset 06576c641113 by Ned Deily in branch 'default':
Issue #16698: merge from 3.3
http://hg.python.org/cpython/rev/06576c641113
msg181235 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-02-03 01:23
The buildbots look happier: closing.
History
Date User Action Args
2013-02-03 01:23:36ned.deilysetstatus: open -> closed
resolution: fixed
messages: + msg181235

stage: commit review -> resolved
2013-02-02 23:14:19python-devsetnosy: + python-dev
messages: + msg181228
2013-02-02 23:01:24ned.deilysetmessages: + msg181227
stage: patch review -> commit review
2013-02-02 22:34:51ned.deilysetfiles: + issue16698_27.patch

nosy: + georg.brandl, benjamin.peterson
messages: + msg181224

keywords: + patch
stage: needs patch -> patch review
2012-12-16 21:34:54ned.deilysetnosy: + ned.deily
messages: + msg177630
2012-12-16 14:05:09rosslagerwallcreate