classification
Title: regression: os.path.split('//hostname/foo/bar.txt')
Type: Stage:
Components: Library (Lib) Versions: Python 3.3, Python 3.2, Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: serhiy.storchaka, techtonik
Priority: normal Keywords:

Created on 2012-11-07 06:15 by techtonik, last changed 2012-11-09 21:38 by jcea. This issue is now closed.

Messages (6)
msg175044 - (view) Author: anatoly techtonik (techtonik) Date: 2012-11-07 06:15
Windows.

Python 3:
>>> import os.path as osp
>>> osp.split('//hostname/foo/')
('//hostname/foo/', '')

Python 2:
>>> osp.split('//hostname/foo/')
('//hostname/foo', '')


But Python 3 again:
>>> osp.split('//hostname/foo/bar/')
('//hostname/foo/bar', '')
msg175046 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-11-07 06:30
'//hostname/foo/' is an UNC path.  Now splitunc() deprecated and splitdrive() works with an UNC paths.

>>> ntpath.splitdrive('//hostname/foo/')
('//hostname/foo', '/')
msg175060 - (view) Author: anatoly techtonik (techtonik) Date: 2012-11-07 09:53
Does that mean that Py3's split() uses splitunc() instead of splitdrive()?
msg175061 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-11-07 09:59
No. splitunc() is deprecated.

http://docs.python.org/3/library/os.path.html#os.path.splitdrive
http://docs.python.org/3/library/os.path.html#os.path.splitunc
msg175062 - (view) Author: anatoly techtonik (techtonik) Date: 2012-11-07 10:32
Ok, so how to fix the regression?
msg175076 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-11-07 10:46
There is not a regression.  This is a feature, not a bug.
History
Date User Action Args
2012-11-09 21:38:40jceasetstatus: open -> closed
2012-11-07 10:46:09serhiy.storchakasetresolution: not a bug
messages: + msg175076
2012-11-07 10:32:38techtoniksetmessages: + msg175062
2012-11-07 09:59:52serhiy.storchakasetmessages: + msg175061
2012-11-07 09:53:56techtoniksetmessages: + msg175060
2012-11-07 06:30:25serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg175046
2012-11-07 06:15:33techtonikcreate