classification
Title: Pylauncher is being installed in Windows system folder
Type: behavior Stage:
Components: Windows Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: cvrebert, eric.smith, ethan.furman, jkloth, loewis, piotr.dobrogost
Priority: normal Keywords:

Created on 2012-10-04 14:53 by piotr.dobrogost, last changed 2012-10-04 17:24 by loewis. This issue is now closed.

Messages (4)
msg171959 - (view) Author: Piotr Dobrogost (piotr.dobrogost) Date: 2012-10-04 14:53
Pylauncher in Python 3.3 is being installed in Windows system folder instead of Program Files folder. That's against platform rules. It should be installed in the same folder Python is installed or in its own folder under Program Files folder. In the former case this folder starting from Python 3.3 is added to PATH, in the latter case there should be an option in installer to add Pylauncher's folder to PATH.

See https://groups.google.com/forum/?hl=en&fromgroups=#!topic/comp.lang.python/-fCFFmpQ8aI
msg171969 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-10-04 16:21
This is not a bug, but by design. See PEP 397 for details.
msg171977 - (view) Author: Piotr Dobrogost (piotr.dobrogost) Date: 2012-10-04 17:16
I read this pep. It doesn't tell why installing in Program Files and adding install folder to PATH wasn't chosen. Please take a look at the link I gave
msg171980 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-10-04 17:24
I read the discussion, but couldn't see anything relevant in it. Please be explicit.

As for the reading the PEP, consider this paragraph in particular:

    It may be surprising that the launcher is installed into the
    Windows directory, and not the System32 directory. The reason is
    that the System32 directory is not on the Path of a 32-bit process
    running on a 64-bit system. However, the Windows directory is
    always on the path.

I think this is quite an explicit rationale.
History
Date User Action Args
2012-10-04 17:24:26loewissetmessages: + msg171980
2012-10-04 17:16:28piotr.dobrogostsetmessages: + msg171977
2012-10-04 16:21:26loewissetstatus: open -> closed

nosy: + loewis
messages: + msg171969

resolution: not a bug
2012-10-04 16:18:36cvrebertsetnosy: + cvrebert
2012-10-04 15:44:15ethan.furmansetnosy: + ethan.furman
2012-10-04 15:14:40jklothsetnosy: + jkloth
2012-10-04 15:08:59eric.smithsetnosy: + eric.smith
2012-10-04 14:53:41piotr.dobrogostcreate