classification
Title: IDLE crashes using clipboard copy command on OS X with ActiveTcl 8.5.12
Type: crash Stage: resolved
Components: IDLE Versions: Python 3.3, Python 3.2, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: ned.deily Nosy List: Leon.Maurer, ned.deily
Priority: normal Keywords:

Created on 2012-08-07 16:48 by Leon.Maurer, last changed 2013-01-12 02:17 by Leon.Maurer. This issue is now closed.

Files
File name Uploaded Description Edit
IDLE crash.rtf Leon.Maurer, 2012-08-07 16:48
Messages (8)
msg167624 - (view) Author: Leon Maurer (Leon.Maurer) Date: 2012-08-07 16:48
I'm getting crashes with IDLE like those that have been reported before (e.g. by trying to copy using Command-C), but I followed (or at least tried to follow) the directions at

http://www.python.org/getit/mac/tcltk/

and have installed Python 2.7.3 64-bit/32-bit and ActiveTcl 8.5.12.

I've attached the crash log. I believe the following lines shows that I am using Tk 8.5.12 and not Apple's buggy version:

0x671000 -   0x76fff7 +Tk 8.5.12 (8.5.12) <BF86DC19-7B3F-BDAA-B650-1DA10C23D73B> /Library/Frameworks/Tk.framework/Versions/8.5/Tk

Thanks.
msg167635 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-08-07 19:27
Ouch! That appears to be a major regression in the newly released ActiveTcl 8.5.12.  I can easily reproduce a crash just using wish8.5 so the problem is strictly in Tcl/Tk itself, not Python.  If you have an older version of ActiveTcl 8.5 available, you can revert to that.  Unfortunately, ActiveState's policy is to only make the most recent Community Edition release openly available on their website.  I've raised this issue on the Mac Tcl mailing list:

http://dir.gmane.org/gmane.comp.lang.tcl.mac
msg167636 - (view) Author: Leon Maurer (Leon.Maurer) Date: 2012-08-07 19:37
Thanks for the quick response. I don't have access to an older version of ActiveTcl, but in truth, I'm mostly relieved that it's not just me. (I spent a long time trying to figure out why some Tkinter code I had written would work on Linux and Windows but not OS X...)
msg167644 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-08-07 22:05
The Mac Tcl community has jumped on the problem and there is now a tentative patch for Tk:

http://permalink.gmane.org/gmane.comp.lang.tcl.core/14173

I've opened a formal issue on the Tcl/Tk bug tracker here:

https://sourceforge.net/tracker/?func=detail&aid=3555211&group_id=12997&a
tid=112997

I'll leave this issue in pending status until the fix has been released and verified in a version of ActiveTcl.  Thanks for the report!
msg168602 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-08-19 22:41
An update: ActiveState has released a Tcl/Tk 8.5.12.1 for OS X and, while it fixes a similar crash-on-copy from within the Wish shell, it doesn't fix the crash-on-copy from within tkinter and IDLE.  Plus, I notice now there's also another regression in 8.5.12.x, a crash when opening IDLE preferences.  Since ActiveTcl only makes available the most recent build in their Community Edition, I would recommend not updating and holding on to 8.5.11.1 until this is resolved.  I'm now able to build Tcl/Tk to reproduce. I'll see if I can bisect it.
msg172465 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-10-09 09:42
I've been able to isolate the problem to a particular Tk checkin and have opened an Tk issue with details here:
https://sourceforge.net/tracker/?func=detail&aid=3575681&group_id=12997&atid=112997
msg178266 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-12-27 03:04
The problem reported here no longer occurs with Tk 8.5.13. See http://www.python.org/download/mac/tcltk/ for important information about using 8.5.13, including a workaround patch for Issue15853 until Python 3.3.1, 3.2.4, and 2.7.4 are released.
msg179753 - (view) Author: Leon Maurer (Leon.Maurer) Date: 2013-01-12 02:17
Thanks for the update. IDLE does indeed work for me now.

Unfortunately, the program I was trying to get working under OS X still has lots of problems. At least it doesn't crash due to copy and paste anymore.
History
Date User Action Args
2013-01-12 02:17:59Leon.Maurersetmessages: + msg179753
2012-12-27 03:04:03ned.deilysetstatus: open -> closed
resolution: out of date
messages: + msg178266

stage: resolved
2012-10-09 09:42:08ned.deilysetmessages: + msg172465
2012-08-19 22:41:28ned.deilysetstatus: pending -> open
resolution: out of date -> (no value)
messages: + msg168602
2012-08-07 22:14:01ned.deilysetstatus: open -> pending
versions: + Python 3.2, Python 3.3
2012-08-07 22:13:30ned.deilysetstatus: pending -> open
title: IDLE crash in OS X even with 2.7.3 and ActiveTcl 8.5.12 -> IDLE crashes using clipboard copy command on OS X with ActiveTcl 8.5.12
2012-08-07 22:05:56ned.deilysetstatus: open -> pending
resolution: out of date
messages: + msg167644
2012-08-07 19:37:35Leon.Maurersetmessages: + msg167636
2012-08-07 19:27:22ned.deilysetassignee: ned.deily
messages: + msg167635
2012-08-07 18:58:11roger.serwysetnosy: + ned.deily
2012-08-07 16:48:17Leon.Maurercreate