classification
Title: ImportError when package is symlinked on Unix
Type: behavior Stage: needs patch
Components: Interpreter Core, Tests Versions: Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: brett.cannon Nosy List: brett.cannon, jason.coombs, ncoghlan, python-dev, wkornewald
Priority: release blocker Keywords:

Created on 2012-06-17 09:04 by jason.coombs, last changed 2012-07-20 18:23 by brett.cannon. This issue is now closed.

Messages (5)
msg163039 - (view) Author: Jason R. Coombs (jason.coombs) * (Python committer) Date: 2012-06-17 09:04
In testing issue6727, I added a test (http://hg.python.org/cpython/rev/afe67ea94bc6) to the default branch. The test passes on Windows, but fails on some of the Unix buildbots. Here's a quick breakdown of where it's passing and failing:

fail:
 x86 Gentoo 3.x
 x86 Gentoo Non-Debug 3.x
 x86 Ubuntu Shared 3.x
 AMD64 FreeBSD 9.0 3.x
 x86 debian parallel 3.x
 x86 RHEL 6 3.x
 ARM Ubuntu 3.x
 x86 Solaris 11 3.x
pass:
 AMD64 Gentoo Wide 3.x
 AMD64 Ubuntu LTS 3.x
 AMD64 OpenIndiana 3.x
 AMD64 Fedora without threads 3.x
 AMD64 Ubuntu LTS bigmem 3.x
 x86 Tiger 3.x
 x86 OpenIndiana 3.x
 x86 FreeBSD 7.2 3.x
 x86 FreeBSD 6.4 3.x

As far as I can tell, the failures don't seem to have an obvious correlation. I will be disabling this test for non-Windows boxes, but it's probably worth tracking down why the test is failing.

I should also note that this test is included in Python 2.7 and does not fail on the Unix.
msg163040 - (view) Author: Roundup Robot (python-dev) Date: 2012-06-17 09:06
New changeset 939a68f5d14c by Jason R. Coombs in branch 'default':
Disable test on Unix. Causes buildbots to fail. See Issue #15091
http://hg.python.org/cpython/rev/939a68f5d14c
msg163047 - (view) Author: Jason R. Coombs (jason.coombs) * (Python committer) Date: 2012-06-17 09:36
I should point out that some of those failures (e.g. x86 Solaris 11 3.x) weren't triggered by the change, but many were.
msg163606 - (view) Author: Jason R. Coombs (jason.coombs) * (Python committer) Date: 2012-06-23 13:31
The test is already present in test_import but is disabled because it is currently failing. I should mention that I believe this is a regression with 3.3 over 3.2. It is certainly a regression over 2.7.
msg165964 - (view) Author: Roundup Robot (python-dev) Date: 2012-07-20 18:22
New changeset 721b701feb4a by Brett Cannon in branch 'default':
Issue #15091: Call importlib.invalidate_caches() and reactivate a test
http://hg.python.org/cpython/rev/721b701feb4a
History
Date User Action Args
2012-07-20 18:23:01brett.cannonsetstatus: open -> closed
assignee: brett.cannon
resolution: fixed
2012-07-20 18:22:34python-devsetmessages: + msg165964
2012-07-20 13:49:06ncoghlansetmessages: - msg165921
2012-07-20 13:25:09ncoghlansetmessages: + msg165921
2012-07-20 13:00:32ncoghlansetpriority: normal -> release blocker
2012-07-20 13:00:13ncoghlansetnosy: + ncoghlan
2012-06-23 13:31:51jason.coombssetmessages: + msg163606
stage: test needed -> needs patch
2012-06-23 05:08:27terry.reedysettype: behavior
components: + Tests
stage: test needed
2012-06-17 09:55:29wkornewaldsetnosy: + wkornewald
2012-06-17 09:36:28jason.coombssetmessages: + msg163047
2012-06-17 09:06:32python-devsetnosy: + python-dev
messages: + msg163040
2012-06-17 09:04:15jason.coombscreate