classification
Title: test_multiprocessing failure on OS X Tiger
Type: behavior Stage: resolved
Components: Library (Lib), Tests Versions: Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: neologix, pitrou, python-dev, sbt
Priority: normal Keywords: patch

Created on 2012-04-25 16:16 by pitrou, last changed 2012-08-16 15:51 by python-dev. This issue is now closed.

Files
File name Uploaded Description Edit
partial_message.patch sbt, 2012-04-26 16:45 review
Messages (6)
msg159312 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-04-25 16:16
The OS X Tiger fails more or less intermittently on one of the new multiprocessing tests:

======================================================================
FAIL: test_pickling (test.test_multiprocessing.WithProcessesTestPicklingConnections)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/test/test_multiprocessing.py", line 2032, in test_pickling
    self.assertEqual(new_conn.recv(100), msg.upper())
AssertionError: b'' != b'THIS CONNECTION USES A NORMAL SOCKET'

http://www.python.org/dev/buildbot/all/builders/x86%20Tiger%203.x/builds/4408/steps/test/logs/stdio
msg159397 - (view) Author: Richard Oudkerk (sbt) * (Python committer) Date: 2012-04-26 16:45
I can't work out what is wrong here.

The code does not to account for a partial read of the message from the socket.  The attached patch fixes that, but it does not address the cause of this failure.
msg159684 - (view) Author: Charles-Fran├žois Natali (neologix) * (Python committer) Date: 2012-04-30 09:16
> I can't work out what is wrong here.

OS-X has known issues with FD-passing over Unix domain sockets, see issues #6560 and #12958.
Since those failures only occur on OS-X buildbots, I'd suggest just skipping them...
msg159695 - (view) Author: Roundup Robot (python-dev) Date: 2012-04-30 13:53
New changeset e64bec91ac91 by Richard Oudkerk in branch 'default':
Issue #14669: Skip multiprocessing connection pickling test on MacOSX
http://hg.python.org/cpython/rev/e64bec91ac91
msg159753 - (view) Author: Charles-Fran├žois Natali (neologix) * (Python committer) Date: 2012-05-01 11:58
The buildbot seems happy, let's close!
msg168390 - (view) Author: Roundup Robot (python-dev) Date: 2012-08-16 15:51
New changeset 4307b985209b by Richard Oudkerk in branch 'default':
Issue #14669: Fix pickling of connections and sockets on MacOSX
http://hg.python.org/cpython/rev/4307b985209b
History
Date User Action Args
2012-08-16 15:51:20python-devsetmessages: + msg168390
2012-05-01 11:58:32neologixsetstatus: open -> closed
resolution: fixed
messages: + msg159753

stage: resolved
2012-04-30 13:53:08python-devsetnosy: + python-dev
messages: + msg159695
2012-04-30 09:16:29neologixsetnosy: + neologix
messages: + msg159684
2012-04-26 16:45:51sbtsetfiles: + partial_message.patch
keywords: + patch
messages: + msg159397
2012-04-25 16:16:50pitroucreate