classification
Title: latent NameError in xmlrpc package
Type: behavior Stage: resolved
Components: Library (Lib), XML Versions: Python 3.2, Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: flox Nosy List: ezio.melotti, flox, pitrou, python-dev
Priority: normal Keywords: patch

Created on 2011-10-29 22:51 by flox, last changed 2011-10-31 20:44 by flox. This issue is now closed.

Files
File name Uploaded Description Edit
issue13291_xmlrpc.diff flox, 2011-10-30 00:59 review
issue13291_xmlrpc_v2.diff flox, 2011-10-30 09:59 review
Messages (7)
msg146622 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2011-10-29 22:51
There's two names which should be fixed in "xmlrpc" package:

--- a/Lib/xmlrpc/client.py
-        elif isinstance(other, (str, unicode)):


--- a/Lib/xmlrpc/server.py
-            response = xmlrpclib.dumps(
-                xmlrpclib.Fault(1, "%s:%s" % (exc_type, exc_value)),


We may extend test coverage too.
msg146625 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2011-10-30 00:59
Proposed fix, with some tests.
msg146627 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2011-10-30 07:13
I left a couple of comments on rietveld.
msg146629 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2011-10-30 09:59
Thank you. Patch updated.
msg146657 - (view) Author: Roundup Robot (python-dev) Date: 2011-10-30 19:26
New changeset f3d454b20b35 by Florent Xicluna in branch '3.2':
Closes #13291: NameError in xmlrpc package.
http://hg.python.org/cpython/rev/f3d454b20b35
msg146725 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-10-31 18:36
Apparently buildbot failures are caused by this commit:


======================================================================
ERROR: test_datetime_before_1900 (test.test_xmlrpc.XMLRPCTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/srv/buildbot/buildarea/3.x.bolen-ubuntu/build/Lib/test/test_xmlrpc.py", line 62, in test_datetime_before_1900
    (newdt,), m = xmlrpclib.loads(s, use_datetime=1)
  File "/srv/buildbot/buildarea/3.x.bolen-ubuntu/build/Lib/xmlrpc/client.py", line 969, in loads
    p.feed(data)
  File "/srv/buildbot/buildarea/3.x.bolen-ubuntu/build/Lib/xmlrpc/client.py", line 430, in feed
    self._parser.Parse(data, 0)
  File "/srv/buildbot/buildarea/3.x.bolen-ubuntu/build/Lib/xmlrpc/client.py", line 662, in end
    return f(self, "".join(self._data))
  File "/srv/buildbot/buildarea/3.x.bolen-ubuntu/build/Lib/xmlrpc/client.py", line 745, in end_dateTime
    value = _datetime_type(data)
  File "/srv/buildbot/buildarea/3.x.bolen-ubuntu/build/Lib/xmlrpc/client.py", line 359, in _datetime_type
    return datetime.strptime(data, "%Y%m%dT%H:%M:%S")
  File "/srv/buildbot/buildarea/3.x.bolen-ubuntu/build/Lib/_strptime.py", line 488, in _strptime_datetime
    tt, fraction = _strptime(data_string, format)
  File "/srv/buildbot/buildarea/3.x.bolen-ubuntu/build/Lib/_strptime.py", line 337, in _strptime
    (data_string, format))
ValueError: time data '10210T11:41:23' does not match format '%Y%m%dT%H:%M:%S'

http://www.python.org/dev/buildbot/all/builders/x86%20Ubuntu%20Shared%203.x/builds/4704
msg146741 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2011-10-31 20:44
This last issue is in the datetime module. issue #13305
History
Date User Action Args
2011-10-31 20:44:40floxsetstatus: open -> closed

messages: + msg146741
2011-10-31 18:36:50pitrousetstatus: closed -> open

nosy: + pitrou
messages: + msg146725

assignee: flox
2011-10-30 19:26:53python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg146657

resolution: fixed
stage: patch review -> resolved
2011-10-30 09:59:17floxsetfiles: + issue13291_xmlrpc_v2.diff

messages: + msg146629
2011-10-30 07:13:08ezio.melottisetnosy: + ezio.melotti
messages: + msg146627
2011-10-30 00:59:12floxsetfiles: + issue13291_xmlrpc.diff
keywords: + patch
messages: + msg146625

stage: test needed -> patch review
2011-10-29 22:51:22floxcreate