classification
Title: launcher can't work on path including tradition chinese char
Type: behavior Stage: resolved
Components: Macintosh Versions: Python 3.4, Python 3.3, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: Ricky.Teng, python-dev, ronaldoussoren
Priority: normal Keywords:

Created on 2011-09-16 10:19 by Ricky.Teng, last changed 2013-07-06 11:27 by ronaldoussoren. This issue is now closed.

Files
File name Uploaded Description Edit
IMG_4359.JPG ricky.teng, 2011-09-21 13:36
Messages (6)
msg144124 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2011-09-16 11:54
Could you please add some more information on how I can reproduce this issue?
msg144377 - (view) Author: Ricky Teng (Ricky.Teng) Date: 2011-09-21 13:55
Excuse me

This is my first time use this bug report.

I have uploaded a jpg to show what I do.

The result is that a console will show and nothing happen.

於 2011/9/16 下午 07:54, Ronald Oussoren 提到:
> New submission from Ronald Oussoren<ronaldoussoren@mac.com>:
>
> Could you please add some more information on how I can reproduce this issue?
>
> ----------
> stage:  ->  test needed
> type:  ->  behavior
>
> _______________________________________
> Python tracker<report@bugs.python.org>
> <http://bugs.python.org/issue12990>
> _______________________________________
>
msg192404 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2013-07-06 10:22
This bug is ancient by now, but not fixed. I've reproduced the issue with a recent release of Python and the problem is an encoding exception in Objective-C:


2013-07-06 12:17:20.511 Python Launcher[43030:f0b] *** Terminating app due to uncaught exception 'NSCharacterConversionException', reason: 'Conversion to encoding 30 failed for string "cd '/Users/ronald/X/..."'


That is because the Python Launcher tries to convert the string to ASCII, and that obviously doesn't work when the path contains Chinese characters. Fixing this should be easy enough, I expect to have a patch later today.
msg192412 - (view) Author: Roundup Robot (python-dev) Date: 2013-07-06 11:20
New changeset 7ec9255d4189 by Ronald Oussoren in branch '2.7':
Issue #12990: The "Python Launcher" on OSX could not launch python scripts that have paths that include wide characters.
http://hg.python.org/cpython/rev/7ec9255d4189
msg192413 - (view) Author: Roundup Robot (python-dev) Date: 2013-07-06 11:26
New changeset 27eb350d5056 by Ronald Oussoren in branch '3.3':
Issue #12990: The "Python Launcher" on OSX could not launch python scripts that have paths that include wide characters.
http://hg.python.org/cpython/rev/27eb350d5056

New changeset b6ebc726d5fe by Ronald Oussoren in branch 'default':
(3.3->default) Issue #12990: The "Python Launcher" on OSX could not launch python scripts that have paths that include wide characters.
http://hg.python.org/cpython/rev/b6ebc726d5fe
msg192414 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2013-07-06 11:27
I've commit a fix for this problem in the branches for 2.7, 3.3 and the upcoming 3.4 release. This means the problem will be fixed in the next releases from those branches.
History
Date User Action Args
2013-07-06 11:27:18ronaldoussorensetstatus: open -> closed
resolution: fixed
messages: + msg192414

stage: test needed -> resolved
2013-07-06 11:26:11python-devsetmessages: + msg192413
2013-07-06 11:20:27python-devsetnosy: + python-dev
messages: + msg192412
2013-07-06 10:22:22ronaldoussorensetversions: + Python 3.3, Python 3.4
2013-07-06 10:22:07ronaldoussorensetmessages: + msg192404
2011-09-21 13:55:51Ricky.Tengsetmessages: + msg144377
title: launcher can't work on path including tradition chinese char -> launcher can't work on path including tradition chinese char
2011-09-21 13:36:12ricky.tengsetfiles: + IMG_4359.JPG
2011-09-16 11:54:27ronaldoussorensettype: behavior
messages: + msg144124
stage: test needed
2011-09-16 10:19:49Ricky.Tengcreate