classification
Title: _socket fails to build on OpenIndiana
Type: compile error Stage:
Components: Build Versions: Python 2.6
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: Bleve, barry, iMil, jcea, pitrou
Priority: normal Keywords:

Created on 2011-04-09 20:49 by iMil, last changed 2011-04-11 14:05 by jcea. This issue is now closed.

Messages (8)
msg133420 - (view) Author: Emile Heitor (iMil) Date: 2011-04-09 20:49
This issue http://bugs.python.org/issue8852 seems to happen again since python 2.6.6. Same cause, same consequences. Patching Modules/socketmodule.h with the following fixes it:

--- Modules/socketmodule.h.orig 2010-05-09 15:15:40.000000000 +0000             
+++ Modules/socketmodule.h                                                      
@@ -59,6 +59,10 @@ typedef int socklen_t;                                       
 #include <bluetooth.h>                                                         
 #endif                                                                         
                                                                                
+#if defined(__sun)                                                             
+#undef HAVE_NETPACKET_PACKET_H                                                 
+#endif                                                                         
+                                                                               
 #ifdef HAVE_NETPACKET_PACKET_H                                                 
 # include <sys/ioctl.h>                                                        
 # include <net/if.h>
msg133423 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-04-09 21:19
It has been fixed in 2.7.x, not 2.6.x (which is in security fixes-only mode).
Can you try with 2.7.1?
msg133425 - (view) Author: Emile Heitor (iMil) Date: 2011-04-09 21:30
Actually, python 2.6 is the default version in pkgsrc (http://www.netbsd.org/docs/software/packages.html), and the reason why i'm pulling up this bug is that python 2.6 failure on SunOS brings down more than 3000 packages :/ Nevertheless, i'll try a bulk build with python 2.7 as the default version, thanks for the heads up.
msg133426 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-04-09 21:42
> Actually, python 2.6 is the default version in pkgsrc
> (http://www.netbsd.org/docs/software/packages.html), and the reason
> why i'm pulling up this bug is that python 2.6 failure on SunOS brings
> down more than 3000 packages :/ Nevertheless, i'll try a bulk build
> with python 2.7 as the default version, thanks for the heads up.

Well, do you need to ship your own build of Python with pkgsrc?
OpenIndiana and recent Solaris versions should AFAIK ship a system
Python 2.6 by default.
msg133428 - (view) Author: Emile Heitor (iMil) Date: 2011-04-09 21:56
Well, pkgsrc is an independent, portable sources-based packaging system which provides a complete set of packages for many architectures. Python is provided as a package per-se, and we do not yet have the ability to fallback to native python version.
If this patch is not to be pulled up to python 2.6 then we'll provide it as a separate patch to pkgsrc, that's really not a problem, i understand perfectly that python 2.6 is now on a maintenance state.

Thanks for your feedback.
msg133448 - (view) Author: Carl Brewer (Bleve) Date: 2011-04-10 07:33
I know this is closed etc... but Plone (the CMS I use) is tied to various versions of Python, in particular 2.6 at this time.  Having it not build on Open[Solaris/Indiana] means I can't install current versions of Plone/Zope on this platform.  Any chance it could be fixed?
msg133454 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-04-10 08:52
> I know this is closed etc... but Plone (the CMS I use) is tied to
> various versions of Python, in particular 2.6 at this time.  Having it
> not build on Open[Solaris/Indiana] means I can't install current
> versions of Plone/Zope on this platform.  Any chance it could be
> fixed?

I would be surprised if Plone/Zope didn't work on 2.7 by the time.
Perhaps you want to ask their mailing-lists.
msg133455 - (view) Author: Carl Brewer (Bleve) Date: 2011-04-10 09:14
Plone ships with a "universal installer" which expects particular versions of python (and PIL etc etc) which makes it easy to build on, for example, many Linux distros, but it's just not working on Open[Solaris|Indiana] and also NetBSD (pkgsrc's python2.6 is broken too, but we're working on that).  The only time the installer gets bumped is when new versions of Plone get released, which means that only the bleeding edge might work.  This is a problem for many integrators who are tied to older versions of Plone|Zope that are unlikely to get migrated to more recent releases in any sort of a reasonable timeframe.

Is it really not possible to fix up python2.6 to solve this issue?
History
Date User Action Args
2011-04-11 14:05:43jceasetnosy: + jcea
2011-04-10 09:19:44pitrousetnosy: + barry
2011-04-10 09:14:01Blevesetmessages: + msg133455
2011-04-10 08:52:50pitrousetmessages: + msg133454
2011-04-10 07:33:06Blevesetnosy: + Bleve
messages: + msg133448
2011-04-09 21:58:27pitrousetstatus: open -> closed
resolution: wont fix
2011-04-09 21:56:23iMilsetmessages: + msg133428
2011-04-09 21:42:19pitrousetmessages: + msg133426
2011-04-09 21:30:30iMilsetmessages: + msg133425
2011-04-09 21:19:23pitrousetnosy: + pitrou
messages: + msg133423
2011-04-09 20:49:37iMilcreate