classification
Title: IDLE's subprocess didnit make connection ..... Python 2.7
Type: behavior Stage: resolved
Components: Windows Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE: inconsistent use of HOMEDRIVE, HOMEPATH, and USERPROFILE on Windows
View: 14576
Assigned To: Nosy List: BreamoreBoy, ltaylor934, plovet, r.david.murray, roger.serwy, terry.reedy
Priority: normal Keywords:

Created on 2010-12-16 23:13 by plovet, last changed 2014-07-10 18:51 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
unnamed plovet, 2010-12-17 18:18
Messages (10)
msg124163 - (view) Author: T Rink (plovet) Date: 2010-12-16 23:13
Hi. 
My problem is that this evening, the message "IDLE's subprocess didn't make connection. Either IDLE can't start a subprocess or personal firewall software is blocking the connection." appears after I hit F5 to run a file I am editing.

The program briefly worked on and off ... but after ca. 10 minutes it stopped for good. 

I have tried searhcing for solutions, but found nothing that seems to work. 

CONFIGURATION:
   Windows Vista 32
   Python 2.7 (downloaded a week ago)
   New User to Python. Amatuer/Hobby Programmer 

SOLUTIONS I HAVE TRIED
-Tried solution "kill process in task manager". No effect. Process was usually already closed by me anyway, but killing it did not help either. 

-Tried solution "repair via .MSI" file. No change.

-Tried to tell Windows Firewall to ignore python and pythonw, that they were acceptable. No change.  

-Would prefer not to "Scrap IDLE" as I just started! (Also I do not want to write Python only in Notepad and use command lines. As much as I love the command line, I do not want that anymore)

-Started to try to use workaround "-n" flag when starting IDLE. 
  a) I would prefer a Solution and not a Workaround that hinders the program before I am started.  
  b) I am new to Python and Idle. Windows Vista hides the links, it is not clear to me how Python is setup and I am still working on understanding how Python operates ... that is pain enough at the moment....

REQUEST:
 -Either a useful suggestion to get IDLE to work properly and as it should. 
 -Or a good recommendation for a universal and Idiot-Friendly alternative Python programming environment. It should be simple, user-friendly, reliable and suitable for novices to experiment (i.e. no complicated setup!) 

(FYI:I spent two years learning Java, and finally canned it, because I got sick of spending my free-time trying to debug and decipher workarounds to what should have been a simple solution! grrrrrrr!)

Thanks to any who can help.
msg124172 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-17 01:25
Perhaps Terry will have some advice (I've added him as nosy), but you may have better luck asking on the python mailing list (see mail.python.org for list of lists) or its linked newsgroup comp.lang.python, or on the #python irc channel (though they may tell you to dump Idle, depending on who is in channel at the time :)

It is not likely that what you are experiencing is an actual bug in Ptyhon, since Idle on windows works for lots of people.  However understanding your problem and its solution might help us make the Idle experience more friendly, so I'll leave it to Terry to decide how he wants to handle this.
msg124246 - (view) Author: T Rink (plovet) Date: 2010-12-17 18:18
Thanks for your comments.

I also expect the problem is the interation of Python with Windows, but
whether they fault lies by Python or Windows I cannot say.

I can say that the problem seems to come and go away.  Last night it did not
work. This morning it did. A few minutes ago it did.  Now it does not.

 I have to my knowledge a standard installation.  Checking Google, which is
where I started in looking for a solution, shows that the error message has
occured for other people as well.

Again any suggestions are appreciated.

Thanks.

On Fri, Dec 17, 2010 at 2:25 AM, R. David Murray <report@bugs.python.org>wrote:

>
> R. David Murray <rdmurray@bitdance.com> added the comment:
>
> Perhaps Terry will have some advice (I've added him as nosy), but you may
> have better luck asking on the python mailing list (see mail.python.orgfor list of lists) or its linked newsgroup comp.lang.python, or on the
> #python irc channel (though they may tell you to dump Idle, depending on who
> is in channel at the time :)
>
> It is not likely that what you are experiencing is an actual bug in Ptyhon,
> since Idle on windows works for lots of people.  However understanding your
> problem and its solution might help us make the Idle experience more
> friendly, so I'll leave it to Terry to decide how he wants to handle this.
>
> ----------
> nosy: +r.david.murray
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue10722>
> _______________________________________
>
msg124326 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-12-18 23:49
I do not have much to add, but second the idea of inquiring on python-list or the gmane mirror, especially about alternatives (other than Notepad, which is what I started with). Happily, IDLE has nearly always worked fine on my xp machine, so I have not tried anything else.

Macs have had more problems than Windows, but perhaps Vista is worse than XP. I will be moving to Windows 7 sometime. The intermittent behavior is, I think, unusual. Please try 3.1.3 or 3.2b1 or .2b2 (in a few days) to see if there is any difference.

It is possible that we could somehow improve the error message or docs.
msg154102 - (view) Author: Larry A. Taylor (ltaylor934) Date: 2012-02-24 01:04
I have had this happen to me many times with Windows XP, the standard OS here. Using IDLE and Python 2.7.

Some of the time the following applies: I have more than one Python Shell open at the same time. The first Python shell/IDLE with debug is running a long job I don't want to interrupt. 

A second IDLE edit window is connected to the second Python shell. I set the shell to debug, then to the edit window with the program, and select 'run'. 

Result: I get the message reported in this issue. Sometimes.

It appears to have nothing to do with firewalls.
msg154105 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2012-02-24 01:40
Some changes have been made to the subprocess connection code since my last message here. I believe they occurred after the last releases. There should be new 2.7.3 and 3.2.3 releases in about a month, after PyCon. Larry, if you can semi-deterministically make the problem happen, please try 3.2 also. I believe the IDLE code is the same for both 2.7 and 3.2, but I have no idea about the subprocess code.
msg158389 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2012-04-16 01:08
3.2.3 and 2.7.3 are out. And I am running on win7 without problems.
I have not tried running multiple shells of the same Python version, but I have occasionally run 2.7 and 3.2 simultaneously without problems that I noticed.

Roger, does IDLE get any info at all from the subprocess failure that it could display?
msg158391 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-04-16 01:27
The IDLE front-end doesn't receive anything about the subprocess failure mode. The "poll_subprocess" method in PyShell.py will restart the subprocess if the socket closes. (The "pollpacket" method in rpc.py raises an EOFError.)
msg222679 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-07-10 17:32
This should be closed as a duplicate of #14576.  There is far more data on that issue and it refers to problems with 3.x.
msg222686 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-07-10 18:51
This has been an occasional problem since forever. It even happened to me yesterday, once, but was solved by shutting things down and restarting.
History
Date User Action Args
2014-10-03 02:13:02terry.reedylinkissue16758 superseder
2014-07-10 18:51:09terry.reedysetstatus: open -> closed
superseder: IDLE: inconsistent use of HOMEDRIVE, HOMEPATH, and USERPROFILE on Windows
messages: + msg222686

resolution: duplicate
stage: resolved
2014-07-10 17:32:40BreamoreBoysetnosy: + BreamoreBoy
messages: + msg222679
2012-04-16 01:27:49roger.serwysetmessages: + msg158391
2012-04-16 01:08:38terry.reedysetmessages: + msg158389
2012-04-16 00:46:40roger.serwysetnosy: + roger.serwy
2012-02-24 01:40:53terry.reedysetmessages: + msg154105
2012-02-24 01:04:00ltaylor934setnosy: + ltaylor934
messages: + msg154102
2010-12-18 23:49:25terry.reedysetmessages: + msg124326
2010-12-17 18:18:52plovetsetfiles: + unnamed

messages: + msg124246
2010-12-17 01:25:22r.david.murraysetnosy: + r.david.murray
messages: + msg124172
2010-12-17 01:22:01r.david.murraysetnosy: + terry.reedy
type: crash -> behavior
2010-12-16 23:13:28plovetcreate